11 Replies Latest reply on Sep 8, 2008 1:31 PM by Chris-anna

    Can't open xpj file

    ouisel3 Level 1
      After months of smooth operation with RoboHelp HTML and RoboHelp server, I tried to open a project file and was told "The file <nameof file> is not a recognized Help Project file and cannot be opened." To diagnose this problem, I tried opening other projects, with the same result. Nor could I create a new project. Time to reinstall RoboHelp, which I did (after uninstalling all pieces) and then installed the 5.01. and 5.02 updates. But when I tried to open the project again, I got the same message. I have not yet rebooted by laptop but I wanted to post this plea in the hope that somebody will recognize it and recommend a fix. Thanks
        • 1. Re: Can't open xpj file
          ouisel3 Level 1
          This problem may have been caused by working with Regedit the previous day. At any rate, the solution was to open RoboHelp for Word, create and save a new project, then exit RoboHelp for Word and reopen RoboHelp HTML. It then is able to recognize .xpj files! Go figure -- big time.
          • 2. Re: Can't open xpj file
            PSIRoboWriter Level 1
            We had this problem recently at my company. None of the fixes worked for us permanently--even rebuilding the user login profile only worked temporarily. We had our developers track this down to the problem....it is that our software install recently started adding MSMXL 2.0 to our install, specifically the msmxl2.dll -- which when removed from our installer stopped causing this problem for us... all is better now that we don't have this MSMXL 2.0 on our computers...later versions are fine MSMXL3 through 7 are fine....
            • 3. Re: Can't open xpj file
              tjwoods23152717 Level 1
              I'm having this issue on my laptop and the ROBOhelp for Word solution did not work for me. I even tried re-installing under a co-workers profile and that still didn't work. Other co-workers can open the same xpj file without issues. I do in fact get this message evertime I open ROBOhelp for Word - "RoboHelp is unable to register MsXml3.dll. If you experience any adverse behavior, please make sure you have sufficient rights and restart the program."

              We have tried registering it with no success, we then get this error:
              DLLRegisterServer in C:\WINDOWS\system32\msxml.dll failed.
              Return code was: 0x80070005

              Any help would be great.
              • 4. Re: Can't open xpj file
                NewtoRobohelp Level 1
                Hi, did you ever find a solution to this? We are receiving the same error message..thanks!
                • 5. Re: Can't open xpj file
                  Peter Grainge Adobe Community Professional (Moderator)
                  Which error message? Several reported in this thread.

                  Do you have JMPS (Joint Mission Planning System) installed on the PC?

                  • 6. Re: Can't open xpj file
                    ouisel3 Level 1
                    Just got a query on the xpj "not recognized" problem. We discovered that a development build of a software product created at our company had inadvertently altered the Windows registry in a way that hosed the RoboHelp client. I don't know which registry entry was affected, but when I uninstalled the build of our software, the xpj file came back intact.
                    • 7. Re: Can't open xpj file
                      NewtoRobohelp Level 1
                      Hi, I am receiving the message "XPJ not recognized" when I try to open any projects on a PC that a technician was recently working on (he was trying to get a Mercury product installed & did make some regedit changes but I don't know what). I tried running the Robohelp for Word fix to no avail. When I copy my project to a network share, other writers can open it so I don't believe it's the project..
                      • 8. Re: Can't open xpj file
                        Peter Grainge Adobe Community Professional (Moderator)
                        Have you tried the other solutions in Snippet 40 on my site?

                        Have you tried reinstalling RH? There's a topic on my site about that.

                        Have you had the technician back?

                        • 9. Re: Can't open xpj file
                          CodyBC Level 1
                          I'm using RoboHelp 6. I started getting the can't open XPJ files error recently. I also found that my Windows update wasn't working. As part of the Windows update fix, I had to re-register the msxml3.dll using the following command: regsvr32 msxml3.dll

                          After I did that and rebooted. I could open the XPJ files again.

                          Thanks,

                          Cody
                          • 10. Re: Can't open xpj file
                            NewtoRobohelp Level 1
                            Thanks Cody! I had tried reinstalling amongst other things to no avail, but re-registering the DLL fixed my problem! FYI, it also allowed me to log onto communicator which I have been having problems with as well.

                            Thanks so much everyone!
                            • 11. Re: Can't open xpj file
                              Chris-anna Level 1
                              This did it for me, too! Thanks - I was quite dreading all the uninstall/reinstall. Neither open with HHP or rename the CPD was working either. I run v7. I noticed first that the opening screen did not display, then that all these "APJ" and "FPJ" files couldn't open. Using a previously saved version from SourceSafe didn't change anything either.

                              This isn't hte first program to give me grief in the last few days. Ran a Java update, and IT distributed some other update. Maybe?