2 Replies Latest reply on Jun 16, 2015 11:40 PM by DemelzaPoldark

    "Cannot connect to fulfillment server" on PC

    Mabeanie

      "Connection error detected

      Digital Editions could not connect to the fulfilment server,

      Please make sure you are connected to the Internet."

      I am connected to the internet. What I am trying to do is download a PDF e-book I bought from Bloomsbury Publishing. The email I used to buy the book was different to that of my Adobe ID. So I changed my Adobe ID to the email I used to buy the book, but it still won't connect and shows up with the same error every time.

      I have tried restarting my computer. I have also deauthorised my previous email on my Adobe account and reset it to the changed one.

      I cannot work out what is wrong.

        • 1. Re: "Cannot connect to fulfillment server" on PC
          shreya Adobe Employee

          try restoring internet explorer to default setttings:

           

          Close any Internet Explorer or Windows Explorer windows that are currently open.

          Open Internet Explorer by clicking the Start button Picture of the Start button. In the search box, type Internet Explorer, and then, in the list of results, click Internet Explorer.

          Click the Tools button, and then click Internet Options.

          Click the Advanced tab, and then click Reset.

          Select the Delete personal settings check box if you would like to remove browsing history, search providers, Accelerators, home pages, and InPrivate Filtering data.

          In the Reset Internet Explorer Settings dialog box, click Reset.

          When Internet Explorer finishes restoring the settings, click Close, and then click OK.

          Close Internet Explorer.Your changes will take effect the next time you open Internet Explorer.

           

          Reference: How to reset Internet Explorer settings

           

          Now LAunch ADE and try again

          • 2. Re: "Cannot connect to fulfillment server" on PC
            DemelzaPoldark

            I started having the same problem this week.  ADE had worked fine until now.  Like you I started by not being able to connect to the fulfillment server.  I tried all the fixes, uninstalled, reinstalled, rebooted, nothing worked, couldn't deauthorize my computer so resorted to the control shift d option, that deauthorized, but then I couldn't authorize my computer, got the error could not connect to the activation server.  I went through all the uninstalling, reinstalling several times, and was getting very frustrated.  Finally I went into my admin account, ADE showed authorized there, tried to add a borrowed library book & it told me that I had to authorize, so I clicked on help, deauthorized, then authorized, the book transferred, plugged in my Kobo Glo & added the book to it.  When I logged off of my admin account & went back to the account I normally use, my ADE still shows that it isn't authorized & the book I added is not in my library.  So I guess I have to use it from my admin account on my computer.  It is kind of annoying, but at least I found a fix that actually worked for me.