4 Replies Latest reply on Jun 7, 2015 9:43 AM by Emilarsen

    InDesign keep options  with layout of RTF import

    Emilarsen

      Hi,

      I have a problem with InDesign handling paragraphs of an imported RTF document completely random.

      The text is for a book, which means it's particularly important that I don't have any widows/orphans on the pages. To avoid that I use the "Keep options" in the paragraph styles.

      Unfortunately these "Keep options" are inconsistent and some times they almost skip entire pages

       

      - - - - - - - - - - - - - -

       

      #1 Screenshot - The RTF is made in Word and saved with the intended formatting, font, breaks etc.

      InDesign-rtf-import-paragraph-handling-1.jpg

      - -

      #2 Screenshot - The InDesign document is made with a Primary text frame and the needed page layout.

      InDesign-rtf-import-paragraph-handling-2.jpg

      - -

      #3 Screenshot - The RTF is imported using the "place" function.

      InDesign-rtf-import-paragraph-handling-3.jpg

      - -

      #4 Screenshot - The RTF is imported with the following options (please note, choosing to keep page breaks doesn't affect the problem).

      InDesign-rtf-import-paragraph-handling-4.jpg

      - -

      #5 Screenshot - As you can see I have an orphan here that I want to get rid of, so I'll use the "Keep options" from the paragraph styles.

      InDesign-rtf-import-paragraph-handling-5.jpg

      - -

      #6 Screenshot - The "Keep option" fixes the problem, however it strangely enough move the two lines to the following page instead of having them on the previous page, which looks like having enough space for them. Anyway, this is a small thing I can live with.

      InDesign-rtf-import-paragraph-handling-6.jpg

      - -

      #7 Screenshot - However, the problem starts when InDesign suddenly breaks paragraphs in strange places. Here you can see there are no breaks between the paragraph and the two lines on the following page. By marking it all you can see I've put in breaks after the two lines, but nothing between the lines.

      InDesign-rtf-import-paragraph-handling-7.jpg

      - -

      #8 Screenshot - As you can see this happens in several places.

      InDesign-rtf-import-paragraph-handling-8.jpg

      - -

      #9 Screenshot - Sometimes it even goes as far as to skip a page. Here there's a picture, but it's just set with a standard wrapping setting. Bear in mind that there are no page breaks here whatsoever. Not in the original file, not in InDesign.

      InDesign-rtf-import-paragraph-handling-9.jpg

      - -

      #10 Screenshot - Even when I delete the Normal style and refer to the basic style (which I then give "Keep options" to avoid orphans etc.) it makes the same mistakes.

      InDesign-rtf-import-paragraph-handling-10.jpg


      - - - - - - - - - - - - - -


      Here are a few things that I've tried without any success...

      • Increase/decrease number of lines in "Keep options"
      • Change font, font size, format to something completely standard like Calibri, Minion Pro, Times, both in source material and InDesign.
      • Increase/decrease mm space between lines in "Indents and spacing".
      • Import with/without page breaks, include options or manually handling style transition.
      • Even when I completely reset the paragraph style and only add the "Keep options", I still get pages with huge gaps (and of course this method is not desired, since I'd have to do the layout all over again).


      PS: The RTF is made with precision, there are no flaws in the document/writing in any of the lines/pages where these problems occur. Furthermore, these mistakes don't occur in the same spots when I change the previous mentioned options.

       

      I hope you can help me out here - and in advance, thanks a lot

      Best regards Emil

        • 1. Re: InDesign keep options  with layout of RTF import
          Willi Adelberger Most Valuable Participant

          In number 6 delete to keep together with next 2 lines.

          In 7: Never use several paragraph breaks in succession, it is a no go.

           

          I would recommend to make all styles in InDesign only as Word has a complete different construction how styles are made. You can use them if you import a document and link an incoming word style to an existing InDesign style, which can be saved as template so you have not much to do if you import RTF with the same style names.

          • 2. Re: InDesign keep options  with layout of RTF import
            Emilarsen Level 1

            Hi Willi,

             

            Thank you for answering on my thread.

             

            6) Regarding number 6, I can't "delete" to move text around. There's only the space between the letters, InDesign have moved the paragraph or parts of it itself. There's nothing inbetween the lines that allows me to modify this, other than of course delete words, which isn't going to help in the long run

            7) It was only to prove a point. It doesn't work no matter how few or many paragraph breaks I have in the text.

             

            I see your point. But it doesn't correlate with our workflow. I'm the one putting it in InDesign, my author writes it in Word and puts the layout according to characters speaking etc., it's not something I can or should do. That's why I'm eager to get this problem solved, because our workflow need it done that way, and probably why Adobe designed the feature in the first place, so we can import without too much trouble.

             

            Thanks and have a good day

            Best regards Emil

            • 3. Re: InDesign keep options  with layout of RTF import
              Willi Adelberger Most Valuable Participant

              With delete I meant with delete is this change which you have to do:

              InDesign-rtf-import-paragraph-handling.png

              But I repeat: InDesign styles have to be edited and created in InDesign. If you import RTF, you have to use InDesign styles, not Word styles to avoid problems.

              • 4. Re: InDesign keep options  with layout of RTF import
                Emilarsen Level 1

                Thanks Willi,

                It works a lot better now.

                 

                I do have a few style challenges, but I've managed to iron out the style setup in Word, making it easier for InDesign to adopt without changing. So I'm much happier now

                 

                Thanks,