1 Reply Latest reply on Jun 7, 2015 2:17 PM by dj_paige

    Lightroom 6/CC won't import images

    RedMustang Level 1

      I recently upgraded to Lightroom 6/CC, and since then I have not been able to import images. I have tried rebooting my Mac, I have tried rebooting Lightroom, and nothing is working. I do get to see the preview photos, but once I click "import," I don't see them again. I gave it quite a long time (fifteen minutes), thinking maybe Lightroom 6/CC just takes longer, but the progress bar isn't showing any movement. It just gets stuck in one place, about 1/4 of the way over from the left, and stops. Any suggestions would be helpful. It sounds like there is a glitch in Lightroom. Is Adobe working on a permanent fix for this issue? And, by the way, EVERYTHING takes longer in Lightroom 6/CC. Very frustrating. You expect upgrades to improve software, not take it a step back.


      I also tried unplugging everything in the other USB ports. I'm not trying to convert to DNG, just trying a plain import. I was able to import the images with Adobe Bridge, so the problem is definitely with Lightroom.