9 Replies Latest reply on Jun 15, 2015 10:49 AM by m_vargas

    Installing latest Flash on Mac Yosemite fails.

    Sam-pling

      2015-06-11 15:38:29.388 Install Adobe Flash Player[70761:6894782] There was an error parsing the Info.plist for the bundle at URL Contents/Info.plist -- file:///Library/QuickTime/FLACImport.component/

      The data couldn’t be read because it isn’t in the correct format.

      <CFBasicHash 0x7871ede0 [0xa0e40cc0]>{type = immutable dict, count = 1,

      entries =>

        0 : <CFString 0xa0e34b64 [0xa0e40cc0]>{contents = "NSDebugDescription"} = <CFString 0x7871ee70 [0xa0e40cc0]>{contents = "Cannot parse a NULL or zero-length data"}

      }

        • 1. Re: Installing latest Flash on Mac Yosemite fails.
          m_vargas Adobe Employee

          Hi Sam-pling,


          We have a few different installer files.  To narrow down which one you are using, what is the name of the file that is not working?

           

          Thank you.

           

          --

          Maria

          • 2. Re: Installing latest Flash on Mac Yosemite fails.
            Sam-pling Level 1

            I tried both versions the pepper (ppapi) one and the other.

            • 3. Re: Installing latest Flash on Mac Yosemite fails.
              m_vargas Adobe Employee

              Hi Sam-pling,

               

              Is this the online or offline installer? The file name is will identify if it's the online installer or offline installer?  I've never seen this behaviour before would like to identify which installer (online or offline) is causing this.  However, it's interesting that it's happening with both the NPAPI and PPAPI installers.

               

              I'd like to get some log files from you. Please read through the FAQWhere do I find the Flash Player installation log on the Macintosh?


              If you're using the offline installer please provide just the first two log files (install.log and FlashPlayerInstallManager.log.


              If you're using the online installer, please provide all 4 log files, and enable Verbose Logging for the online installer log files (files 3 & 4).  Instructions to enable Verbose Logging is included in the FAQ.


              After you've attempted the re-install and gathered all the log files, please upload them using the instructions: The specified item was not found.


              Post the link to the log files in your reply.

               

              Thank you.

               

              --

              Maria

              • 4. Re: Installing latest Flash on Mac Yosemite fails.
                Sam-pling Level 1

                I have tried the Online Installer i think but i'll try both.

                 

                By the way i coldn't manage to install flash sinze the last 3 versions the 4th i also had trouble but i could at least install it through chrome with the online installer but since then i havn't been able to install a new version.

                 

                i'm out of office till next thurstday so i don't have access to my mac i'll try it then and upload my log files.

                • 5. Re: Installing latest Flash on Mac Yosemite fails.
                  John Blackburne Level 1

                  New download from get.adobe.com just crashed in the installer. Here's I think the relevant bit of the crash log.

                   

                  Process:               Install Adobe Flash Player [29475]

                  Path:                  /Volumes/VOLUME/Install Adobe Flash Player.app/Contents/MacOS/Install Adobe Flash Player

                  Identifier:            com.adobe.InstallAdobeFlashPlayer

                  Version:               1.0.0.19s (1.0.0.19s)

                  Code Type:             X86 (Native)

                  Parent Process:        ??? [1]

                  Responsible:           Install Adobe Flash Player [29475]

                  User ID:               503

                   

                   

                  Date/Time:             2015-06-13 01:53:41.152 +0100

                  OS Version:            Mac OS X 10.10.3 (14D136)

                  Report Version:        11

                  Anonymous UUID:        76A86DF7-F01D-3A2D-87E4-CD77894613AD

                   

                   

                  Sleep/Wake UUID:       247BDBB2-C78D-4EB4-8AD0-71DDC05DDA06

                   

                   

                  Time Awake Since Boot: 580000 seconds

                  Time Since Wake:       53000 seconds

                   

                   

                  Crashed Thread:        0  Dispatch queue: com.apple.main-thread

                   

                   

                  Exception Type:        EXC_BAD_ACCESS (SIGSEGV)

                  Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000008e00

                   

                   

                  VM Regions Near 0x8e00:

                  -->

                      __TEXT                 000000000000c000-00000000000be000 [  712K] r-x/rwx SM=COW  /Volumes/VOLUME/Install Adobe Flash Player.app/Contents/MacOS/Install Adobe Flash Player

                   

                   

                  Application Specific Information:

                  objc_msgSend() selector name: objectForKey:

                   

                   

                   

                   

                  Thread 0 Crashed:: Dispatch queue: com.apple.main-thread

                  0   libobjc.A.dylib               0x952820ab objc_msgSend + 27

                  1   com.apple.CoreFoundation       0x98f88363 __CFBundleGetDevelopmentRegion_block_invoke + 51

                  2   libdispatch.dylib             0x959b4130 _dispatch_client_callout + 50

                  3   libdispatch.dylib             0x959b40b5 dispatch_once_f + 251

                  4   libdispatch.dylib             0x959b50d8 dispatch_once + 31

                  5   com.apple.CoreFoundation       0x98ec2a5d CFBundleGetDevelopmentRegion + 93

                  6   com.apple.CoreFoundation       0x98ec2c3f CFBundleCopyBundleLocalizations + 479

                  7   com.apple.CoreFoundation       0x98fa8fba _CFBundleCopyLanguageSearchListInBundle + 42

                  8   com.apple.CoreFoundation       0x98ec1599 _CFBundleCopyQueryTable + 41

                  9   com.apple.CoreFoundation       0x98ec0e4b _CFBundleCopyURLsOfKey + 347

                  10  com.apple.CoreFoundation       0x98ec0514 _CFBundleCopyFindResources + 1108

                  11  com.apple.CoreFoundation       0x98ec00b5 CFBundleCopyResourceURL + 85

                  12  com.apple.CoreFoundation       0x98ebff31 CFBundleGetLocalInfoDictionary + 97

                  13  com.apple.CoreFoundation       0x98ebfe90 CFBundleGetValueForInfoDictionaryKey + 32

                  14  com.apple.HIToolbox           0x99746331 islCreateInputMethodIsSelectable_Common + 240

                  15  com.apple.HIToolbox           0x99744a67 islCreateInputMethodIsSelectable + 16

                  16  com.apple.HIToolbox           0x995802b9 islPopulateInputSourceProperty + 4057

                  17  com.apple.HIToolbox           0x9957f035 islGetInputSourceProperty + 68

                  18  com.apple.HIToolbox           0x9957ef3c TSMGetInputSourceProperty + 468

                  19  com.apple.HIToolbox           0x9958f37b _CreateKeyboardInputSourcesArray_Mutable + 551

                  20  com.apple.HIToolbox           0x9958f8ab _CreateKeyboardInputSourcesArray + 24

                  21  com.apple.HIToolbox           0x9958f6b6 SectSelectableInputSourcesArrayFromCurrentState + 98

                  22  com.apple.HIToolbox           0x9958ba25 MyActivateTSMDocument + 862

                  23  com.apple.HIToolbox           0x9958eac7 CallMyActivateTSMDocument + 97

                  24  com.apple.HIToolbox           0x9958e9e6 TimerVector + 22

                  25  com.apple.CoreFoundation       0x98f2a006 __CFRUNLOOP_IS_CALLING_OUT_TO_A_TIMER_CALLBACK_FUNCTION__ + 22

                  26  com.apple.CoreFoundation       0x98f29ab4 __CFRunLoopDoTimer + 1316

                  27  com.apple.CoreFoundation       0x98fa554f __CFRunLoopDoTimers + 351

                  28  com.apple.CoreFoundation       0x98ee1531 __CFRunLoopRun + 2081

                  29  com.apple.CoreFoundation       0x98ee0aa6 CFRunLoopRunSpecific + 390

                  30  com.apple.CoreFoundation       0x98ee090b CFRunLoopRunInMode + 123

                  31  com.apple.HIToolbox           0x9957a8f8 RunCurrentEventLoopInMode + 262

                  32  com.apple.HIToolbox           0x9957a631 ReceiveNextEventCommon + 494

                  33  com.apple.HIToolbox           0x9957a42c _BlockUntilNextEventMatchingListInModeWithFilter + 99

                  34  com.apple.AppKit               0x90544721 _DPSNextEvent + 742

                  35  com.apple.AppKit               0x90543dc5 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 350

                  36  com.apple.AppKit               0x9053877c -[NSApplication run] + 907

                  37  com.apple.AppKit               0x904adbc0 NSApplicationMain + 2082

                  38  com.adobe.InstallAdobeFlashPlayer 0x00044ee0 main + 832

                  39  com.adobe.InstallAdobeFlashPlayer 0x0000df35 start + 53

                  • 6. Re: Installing latest Flash on Mac Yosemite fails.
                    John Blackburne Level 1

                    It worked on second attempt, for no obvious reason. Safari was running throughout; no instances of Flash Player were running.

                    • 7. Re: Installing latest Flash on Mac Yosemite fails.
                      m_vargas Adobe Employee

                      Hi,


                      Thank you for posting the crash log file and an update that the installer worked the second time around.  To investigate further and try to find out why it crashed, did you do anything different from the first install attempt to the second?   On the first attempt, did you launch the installer file from the location it was saved to after downloading or did you launch the installer from the download dialog window?  Something else?

                       

                      Thank you in advance.

                       

                      --

                      Maria

                      • 8. Re: Installing latest Flash on Mac Yosemite fails.
                        John Blackburne Level 1

                        Nothing different that I can recall. I had Safari open throughout, noticing the announcement that it no longer needed to be closed. I made sure that no web pages had Flash running in them each time, though will have opened and closed some windows inbetween.

                         

                        First time I will have opened it by double clicking on the icon in the downloaded disk image. Of course only first time did I get the Macs "are you sure you want to run this, downloaded from xxx" dialog.

                         

                        I am not  sure how I launched it second time. It might have been through "Recent items" in the Apple menu. Or again by double clicking on the icon, in the still mounted disk image. Second time there was no dialog asking me if I wanted to run it. Apart from that I don't know what was different. I certainly didn’t restart or log off between attempts.

                        • 9. Re: Installing latest Flash on Mac Yosemite fails.
                          m_vargas Adobe Employee

                          Hi,

                           

                          Thanks for confirming the difference in how it was launched.  I will pass on this information to the folks who handle the online installer to investigate.

                           

                          As for not having to restart the browser for installation to complete, the message indicates the browser may need to be restarted.  This is because some browsers (Safari being one of them) do need to be restarted for the new version to load.  We're working with Apple to change this, but no estimate on when/if it'll actually be implemented by Apple in Safari.  Firefox doesn't need to be restarted to load the newly installed version.  Just refresh the tab or open a new tab and the newly installed version will load.  We considered having browser specific messaging but ultimately decided against it since browser behaviour may change and then the messaging would not be accurate.

                           

                          --

                          Maria