3 Replies Latest reply on Jul 8, 2015 3:54 PM by gps85641836

    After upgrading to new version Digital Editions won't open.  It's in the task bar, but never completely opens.

    g.s95058251

      I've used Digital Editions for quite a while, mostly for library eBooks.  Recently I bought an Android tablet and wanted to read an eBook I bought from Kobo on it.  I had previously downloaded the eBook onto DE and was able to read it fine there on the PC.  I then downloaded the eBook to my tablet and went through the hoops to have it registered on the tablet.  I wouldn't be surprised if I could no longer read it on the PC but when I tried to do so DE wouldn't open on the PC, at all.  It does show up in the task bar but never opens up a window.  I've reinstalled and nothing changed.  I left it up while I ran an errand and nothing had changed when I returned.  I'm now at a loss and looking for guidance on how to proceed, or what else to try.  I'm no expert on DE but need it for eBooks, primarily.  I called support and they sent me to the experts here on the forums. 

       

      Any thoughts?

       

      Glen