33 Replies Latest reply on Feb 16, 2017 8:52 AM by pbroom

    How to permanently disable Libraries CC

    h_cline2 Level 1

      I am working in InDesign CC 2014 latest version. Every time I open up InDesign the Libraries CC panel always and I mean always opens up even if I've closed it out in every previous session. I cannot figure out how to permanently turn it off or disable it. I don't use it. I don't need it and it's an annoying pop up.

       

      Working on a Mac OS running Yosemite 10.10.3

      3.06 GHz Intel Core 2 Duo - Processor

      16 GB 1067 MHz DDR3 - RAM

      NVIDIA GeForce 9400 256 MB - Graphics Card

       

      Can anyone help me to permanently disable this thing. It's annoying and useless to me.

       

      Thanks.

        • 1. Re: How to permanently disable Libraries CC
          Steve Werner Adobe Community Professional & MVP

          Go through your workspaces in the Workspace menu. In each workspace in which CC Libraries exists, drag the panel out of your dock, and close it. Resave your workspace (using the same name if you wish, replacing the old version).

           

          It will no longer appear.

          • 2. Re: How to permanently disable Libraries CC
            kristinal26062840

            Doesn't work. Every time I make a style, it opens back up. And I'm pretty sure it is crashing InDesign because my document was working just fine yesterday.

            • 3. Re: How to permanently disable Libraries CC
              Steve Werner Adobe Community Professional & MVP

              Try asking in the Adobe Creative Cloud forum. There are support engineers who understand the fine points of the CC features there.

               

              AdobeCreative Cloud

              • 4. Re: How to permanently disable Libraries CC
                AprilCopperline Level 1

                Hey fellow-sufferer!

                Did you find a solution? I just posted a nearly identical query in the Creative Cloud forum. . . .

                 

                ugh.

                --April

                • 5. Re: How to permanently disable Libraries CC
                  Anasuiya Gupta Adobe Employee

                  For your particular case, if you are using InDesign CC 2015, then there is a checkbox, Add to CC Library, in the New Character Style and New Paragraph Style Dialog which adds the style directly to the selected library and opens the CC Libraries Panel. If you do not want the style to be added to the CC Libraries at the time of creation, then simply uncheck the checkox at the bottom of the dialog.

                  • 6. Re: How to permanently disable Libraries CC
                    Anasuiya Gupta Adobe Employee

                    Try trashing your ID preferences. Launch InDesign then undock the CC Libraries Panel and dismiss it.

                    Let me know what happens after you relaunch InDesign, does the CC Libraries panel opens up on launch ?

                    • 7. Re: How to permanently disable Libraries CC
                      AprilCopperline Level 1

                      I had the same problem and kind member, Ellis, sent me this! It's the same solution provided by Anasulya Gupta in this thread. . . .

                      CC Library popping up when creating swatches—figured it out

                      • 8. Re: How to permanently disable Libraries CC
                        Sue@Jump Level 1

                        I have the same issue. Can we have the option for this to be disabled please?

                        • 9. Re: How to permanently disable Libraries CC
                          Steve Werner Adobe Community Professional & MVP

                          Sue,

                           

                          You can disable the appearance of the library panel when adding new swatches or styles:

                           

                          CC Library popping up when creating swatches—figured it out

                          1 person found this helpful
                          • 10. Re: How to permanently disable Libraries CC
                            Sue@Jump Level 1

                            Hi Steve, thank you for the reply. I saw the button in the Swatches and Styles Panels etc, but the actual CC Libraries Panel opens up by default each session.

                            I have closed the Panel and re-saved the Workspace but it still appears on fresh login. I think it is hard coded to pop up, maybe.

                            • 11. Re: How to permanently disable Libraries CC
                              Steve Werner Adobe Community Professional & MVP

                              I believe it may be programmed to pop open the first time you open InDesign. But after turning off the buttons in the Swatches and styles panels, it doesn't open unless I click on it. You probably can't do better than that right now.

                              • 12. Re: How to permanently disable Libraries CC
                                KrisHunt Level 4

                                If you do not want the style to be added to the CC Libraries at the time of creation, then simply uncheck the checkox at the bottom of the dialog.

                                 

                                It is not that simple! I have unchecked the checkbox dozens of times, and it keeps re-checking itself! It shouldn't even be checked by default. Why would the default behavior be to keep a library of every single paragraph and character style I ever make, all jumbled together in one meaningless collection?!

                                 

                                Furthermore, I keep deleting the "My Library" file, which then results in a "Library syncing is disabled..." message along with an "Enable" button. I never ever check the Enable button, yet somehow it keeps getting enabled. This feature is garbage, and I too want it gone forever.

                                1 person found this helpful
                                • 13. Re: How to permanently disable Libraries CC
                                  Steve Werner Adobe Community Professional & MVP

                                  @Kris,

                                   

                                  It's definitely supposed to be a sticky setting, and it is for me.

                                   

                                  Try restoring your InDesign preferences to see if that helps:

                                   

                                  Trash, Replace, Reset, or Restore the application Preferences

                                  1 person found this helpful
                                  • 14. Re: How to permanently disable Libraries CC
                                    KevinAtkins Level 1

                                    Just to add my experience: even though I don't use libraries, CC Library fails to sync to Adobe servers, and this is causing a 2 second delay after every single operation in InDesign ... it's now unuseable.

                                     

                                    That this cannot be turned off – and I mean turned off, not hidden from view – is ridiculous. Forcing 'features' upon is one thing, but when this feature prevents the app working, it's ridiculous.

                                     

                                    Either give us the option of disabling it fully, or make sure it works.

                                    1 person found this helpful
                                    • 15. Re: How to permanently disable Libraries CC
                                      Vhalor Level 1

                                      Please allow us to disable the CC library in indesign!! So far, the only place I use it is in illustrator, but I have no desire at all to use it in indesign, much less.. to save every single one of my styles in a really messy way! I work on several projects for different brands, with WAYYY too different styles. Some of my indesign documents are really large publications with different sections and different styles for each section... imagine the mess! *sigh* this is very frustrating.

                                      • 16. Re: How to permanently disable Libraries CC
                                        LTsalis

                                        I'm going to have to agree. This new "feature" is slowing down my workflow. Need an option to turn it off completely.

                                        • 17. Re: How to permanently disable Libraries CC
                                          charlotte221

                                          Adding my agreement to disable completely. It's driving me and my coworker nuts.

                                          • 18. Re: How to permanently disable Libraries CC
                                            Steve Werner Adobe Community Professional & MVP

                                            I appreciate your desire to disable CC Libraries. However, the proper people don't read this forum regularly.

                                             

                                            You'll have more impact if you all go to this website and file a feature request:

                                             

                                            Feature Request/Bug Report Form - Adobe

                                            2 people found this helpful
                                            • 20. Re: How to permanently disable Libraries CC
                                              SharpenedLyrics

                                              My post to another forum topic about CCLibraries causing performance issues with Indesign:

                                               

                                              I have been struggling with this issue for a number of weeks. The problem we had with the CCLibraries process is that our firewall and proxy server are not currently allowing connectivity to all of Adobe's servers, therefore quitting the CCLibraries process and re-starting Indesign never worked, there was always a problem with CCLibraries.

                                               

                                              The solution (temporary until Adobe update Indesign) is to permanently disable CCLibraries. How do you do this? Simple -

                                              1. Quit Indesign

                                              2. Find [Hard Disk] > Applications > Utilities > Adobe Creative Cloud and copy the folder called CCLibrary to your desktop (or somewhere that you want to store it)

                                              3. Delete CCLibrary folder from [Hard Disk] > Applications > Utilities > Adobe Creative Cloud.

                                              4. Re-open Indesign

                                              5. I also followed the above steps to uncheck "Save to CC Library" in the Swatches, Character Styles and Para Styles panels. Then quit and re-opened Indesign again to ensure these prefs stick.

                                               

                                              NO MORE LAG! No more CC Libraries either but I can deal with that until Adobe fix.

                                               

                                              UPDATE 15/9/15 - CCLibrary folder seems to regenerate so I had to delete it again this morning. Gah!! I'm not sure how to stop this from happening, it might not even be possible.

                                               

                                              Still, at least now there seems to be a way to get the apps to work correctly. If Indesign slows down again, quit all Adobe apps incl. CC Desktop, check the folder, delete the CCLibrary folder again.

                                              • 21. Re: How to permanently disable Libraries CC
                                                cassied98634242

                                                Hi, Adobe Creative Cloud doesn't appear in my utilities folder?

                                                • 22. Re: How to permanently disable Libraries CC
                                                  Sue@Jump Level 1

                                                  Hi Anasuiya, I'm wondering who marked that as the correct answer...

                                                   

                                                  There is also one in the Swatches Panel and you have to uncheck them ALL!

                                                  Even when I had these all unchecked the panel kept re-appearing on launching InDesign.

                                                  I also remember (in desperation) going to my Creative Cloud Account and disabling syncing in the Preferences, then coming back into InDesign, trashing preferences, restart, un-checking all three CC Library boxes (Char Styles, Para Styles and Swatches) closing down the CC Libraries Panel then resetting preferences and resaving my workspace settings.

                                                  I re-enabled syncing after doing all of that, and the panel no longer comes up at launch.

                                                  I think that was everything... from memory...

                                                  • 23. Re: How to permanently disable Libraries CC
                                                    Anasuiya Gupta Adobe Employee

                                                    Hi Sue

                                                     

                                                    That reply was for kristinal26062840's problem on adding styles. You are correct that the checkbox to Add to CC Library exists in the new Swatch, Character Style and Paragraph Style dialog. But after un-checking all these, the CC Libraries panel should never popup unless you had it open or docked in your workspace. But, if that still happens then please let me know.

                                                     

                                                    Regards

                                                    Anasuiya Gupta

                                                    • 24. Re: How to permanently disable Libraries CC
                                                      charlotte221 Level 1

                                                      Thank you @SharpenedLyrics; that worked for me! Thanks!!

                                                      I have been struggling with this issue for a number of weeks. The problem we had with the CCLibraries process is that our firewall and proxy server are not currently allowing connectivity to all of Adobe's servers, therefore quitting the CCLibraries process and re-starting Indesign never worked, there was always a problem with CCLibraries.

                                                       

                                                      The solution (temporary until Adobe update Indesign) is to permanently disable CCLibraries. How do you do this? Simple -

                                                      1. Quit Indesign

                                                      2. Find [Hard Disk] > Applications > Utilities > Adobe Creative Cloud and copy the folder called CCLibrary to your desktop (or somewhere that you want to store it)

                                                      3. Delete CCLibrary folder from [Hard Disk] > Applications > Utilities > Adobe Creative Cloud.

                                                      4. Re-open Indesign

                                                      5. I also followed the above steps to uncheck "Save to CC Library" in the Swatches, Character Styles and Para Styles panels. Then quit and re-opened Indesign again to ensure these prefs stick.

                                                      • 25. Re: How to permanently disable Libraries CC
                                                        SharpenedLyrics Level 1

                                                        Glad to hear it's working for you charlotte221

                                                         

                                                        I think I should add a couple of steps and clarification to the process though to ensure that it works for everyone.

                                                         

                                                        The solution (temporary until Adobe update Indesign) is to disable CCLibraries. How do you do this? Simple -

                                                        1. Quit Indesign and quit Adobe Creative Cloud desktop app (the cloud icon in your menu bar)

                                                        2. Go to Activity Monitor, find CCLibraries process and quit that.

                                                        3. Find [Hard Disk] > Applications > Utilities > Adobe Creative Cloud and copy the folder called CCLibrary to your desktop (or somewhere that you want to store it)

                                                        4. Delete CCLibrary folder from [Hard Disk] > Applications > Utilities > Adobe Creative Cloud.

                                                        5. Re-open Indesign and re-open Adobe Creative Cloud desktop app

                                                        6. I also followed the steps in earlier posts to uncheck "Save to CC Library" in the Swatches, Character Styles and Para Styles panels. Then quit and re-opened Indesign again to ensure these prefs stick.

                                                         

                                                        Adobe Creative Cloud desktop app will periodically update itself to the "latest version" which is, in fact, just it re-installing the CCLibrary folder to make it sync with v2.2.0.129. This normally happens after a restart or full logout but can also just happen seemingly randomly. If this happens then the lag will return and you will need to go through the steps above again.

                                                         

                                                        Good luck to us all!

                                                        • 26. Re: How to permanently disable Libraries CC
                                                          gunnarlinn Level 1

                                                          +1 on this. I don't want the panel to pop up every time I start up InDesign. It just annoys me. I don't use libraries, and I don't want to feel that Adobe really really really wants me to.

                                                          • 27. Re: How to permanently disable Libraries CC
                                                            BriGuyAG Level 1

                                                            Hi, all, and thanks for linking that solution I posted back in June—you're welcome!

                                                             

                                                            I am seeing this behavior pop up, again, from time to time, myself. When I launch InDesign for the first time after quitting it (for whatever reason—usually to apply an update [most common] or because it's crashed [infrequent]), the CC Libraries palette will open at first (while ID is in the process of launching), then go away when ID is finished starting up. Kinda weird. I get PO'ed at first when I see that right off the bat, but then it goes away and I'm like, "OK, phew! Jeez..."

                                                             

                                                            Similarly when I apply an update to ID, the welcome screen turns back on again, even though I click on "Don't show me this again" every single time -- it just keeps turning itself back on with new updates. So, it seems that some preferences are being reset when updating. *shrug*

                                                            • 28. Re: How to permanently disable Libraries CC
                                                              kalbrandon

                                                              Is it possible to describe these steps for a PC (Windows 10). I am having the same issue and cannot resolve it using the MAC steps--perhaps something does not directly translate between PC and MAC, or maybe additional step(s) are required?

                                                              • 29. Re: How to permanently disable Libraries CC
                                                                BriGuyAG Level 1

                                                                Feature Request/Bug Report Form - Adobe

                                                                 

                                                                Maybe try that link -- user AprilCopperline has added some screenshots in there that might help you, regarding the unchecking of the "Add to CC Library" box when adding new swatches/styles.

                                                                 

                                                                I don't work on a PC, but I figure that InDesign's menus are identical cross-platform, just where/how they're accessed may be a bit different (i.e. instead of Preferences, you might be looking for Tools or Options or something). So, adjust as needed for the Windows side of things.

                                                                 

                                                                Basically, launch InDesign with no document open, uncheck the CC Libraries window to disable it (top of screen -> Window -> CC Libraries)...

                                                                Screen Shot 2015-11-15 at 10.42.37 AM.png

                                                                 

                                                                ...then add new swatches and paragraph/character styles (maybe before even opening a document, so that it applies to all new documents from that point on), but when doing so, remember to UNCHECK the "Add to CC Library" box before hitting OK (again, see AprilCopperline's screenshots at the link above). Then, hit OK to add the swatch/styles, then quit and relaunch InDesign (you can then remove those swatches/styles if you don't want to keep them).

                                                                 

                                                                Also, you may want to check your Sync settings and disable them, if you don't use them: InDesign -> Preferences (or Options or whatever it is on the PC) -> Sync Settings:

                                                                Screen-Shot-2015-11-15-at-10.43.12-AM.png

                                                                 

                                                                Once you have the Sync Settings window open (see below), set the "Sync:" drop-down menu to "None" in the "Sync Settings Options" section. Then, click the "Manage Account..." button on the right, which will open your default browser and take to your Sync Settings page at Adobe's website (after prompting you to log in, that is):

                                                                Screen-Shot-2015-11-15-at-10.43.27-AM.png

                                                                 

                                                                Once there, clear whichever Sync settings you'd like (just click either "Clear Settings" for a specific program or "Clear All" to get rid of them all in one fell swoop):

                                                                Screen Shot 2015-11-15 at 10.43.49 AM.png

                                                                Then, go back to InDesign (your Sync Settings window should still be open) and hit OK.

                                                                1 person found this helpful
                                                                • 30. Re: How to permanently disable Libraries CC
                                                                  robinbeatty

                                                                  This easy solution worked for me on Indesign CC 2017: Open Indesign, but don't open any docs.

                                                                   

                                                                  Don't close CC Libraries panel but instead uncheck Window > CC Libraries

                                                                   

                                                                  Restart Indesign. Hasn't reappeared since without me choosing it.

                                                                  • 31. Re: How to permanently disable Libraries CC
                                                                    Michael Bojkowski Level 1

                                                                    I'm having the same issue. I'm in Australia where broadband generally sucks. Every time the CC Libraries panel re-launches I get the beachball of death while it tries to connect to... whatever... online. It's starting to drive me crazy. Fix this Adobe!

                                                                    • 32. Re: How to permanently disable Libraries CC
                                                                      Michael Bojkowski Level 1

                                                                      Not good enough Adobe. Should be a way to easily disable all CC Library activity. It interrupts natural workflow too requently.

                                                                      • 33. Re: How to permanently disable Libraries CC
                                                                        Steve Werner Adobe Community Professional & MVP

                                                                        Sorry, I don't think that's going to happen. All the new features are built to be connected via Creative Cloud.

                                                                         

                                                                        You can file a feature request here, but....

                                                                         

                                                                        Feature Requests/Bug Reports

                                                                        • 34. Re: How to permanently disable Libraries CC
                                                                          pbroom Level 1

                                                                          I have had this exact problem in Animate CC and I'm guessing my "solution" will apply to InDesign too. While my "solution" doesn't completely remove CC LIbraries from the interface/workspace, it does get it neatly hidden away in a location I can readily ignore.

                                                                           

                                                                          Here's how I have worked around the issue (given that there was no clear "Settings" option for "Don't expand any panels or tabs when the application is first loaded"):

                                                                           

                                                                          1. I opened the application and as usual, the CC Libraries panel was open. I still don't remember opening that thing ever...Grrr....oh well...
                                                                          2. I clicked Window in the menu bar and unchecked CC Libraries
                                                                          3. Since I rarely use CC Libraries I moved the closed CC Libraries tab into a side panel (I moved it to where "Properties" and "Library" are shown in this image http://ptgmedia.pearsoncmg.com/images/art_labrecque_flashprocc/elementLinks/Labrecque_fig0 1.png)
                                                                          4. Next I clicked on Properties in the same side panel I moved CC Libraries to. "Properties" is what I prefer to have be the default panel open when I open a file and I'm fairly sure you could easily choose another option.
                                                                          5. Then I clicked on the current Workspace name, selected New Workspace and named the Workspace.
                                                                          6. Then I clicked the Sync Settings button followed by Sync Now.
                                                                          7. Closed the application
                                                                          8. Reopened the application and no CC Libraries showing by default. Ahhhhh.

                                                                           

                                                                          I hope this works for anyone trying to have a clean workspace... and I'm imagining the process might work for any sort of re-configuring and customizing of the CC application interfaces.