8 Replies Latest reply on Jun 15, 2015 3:13 PM by martinbach

    Robohelp 8. Creating new topics

    martinbach

      After years of using RoboHelp 8, I find that all of a sudden I cannot do the following in existing projects:

      • If I select New>Topic then instead of a new, blank topic page being generated, the 'bell' sounds and nothing happens.
      • If I right click on a topic in the Project Manager and select 'Properties', again the 'bell' sounds and the Properties dialogue does not show.

      In both cases, hitting the Escape key 'gets me out' of these conditions.

       

      As an aside, when I start Robohelp I get a message from UAC saying that the Internet Explorer Add-On Installer is trying to run. Given that I have NOT requested automatic updates I decline. This has been going on for a few weeks, and other than the annoyance of getting this, Robohelp continues to work after cancelling the update.

       

      Oddly, today there was a similar message about installing a Flash Plug-in (I think - I've only seen the message once). Again I declined as in both cases I'm worried that installing either of these will mess up Robohelp as Robohelp 8 is quite old, whereas these plug-ins are obviously up-to-date.

       

      However, I wonder if there is a connection betwen my 'new problems' (as above) and the appearence of this new, Flash update.

       

      Anyone have any suggestions?

       

      The LAST thing I would want to try is to tre-install Robobhelp 8!  I'd be really concerned that this simply will not work given the pasge of time.

        • 1. Re: Robohelp 8. Creating new topics
          Captiv8r Adobe Community Professional & MVP

          Hmmm, what you are describing sounds as if a dialog is appearing SOMEWHERE, but you are unable to see it.

           

          I might suggest resizing the RoboHelp application window so it's quite small, then move it to a corner of the screen and press Ctrl+t (the shortcut to create a new topic). See if the dialog is maybe appearing BEHIND the RoboHelp application window? I've seen odd things with computers where this sometimes happens.

           

          Cheers... Rick

          • 2. Re: Robohelp 8. Creating new topics
            martinbach Level 1

            Rick

             

             

             

            Thanks for the suggestion - but that's not it; I tried what you proposed but there is no dialogue showing.

             

             

             

            As an aside, I tried 'Duplicate Topic' with the same effect. So it seems that any 'action' associated with topics is failing, viz:

             

             

             

            ·         Create new topic

             

            ·         Duplicate Topic

             

            ·         See Topic Properties

             

             

             

            Regards

             

             

             

            Martin

            • 3. Re: Robohelp 8. Creating new topics
              Captiv8r Adobe Community Professional & MVP

              Okay, this is a long shot, but might be worth trying.

               

              If you have a Windows keyboard, press the Windows logo key and the letter P. Choose Duplicate if you can. Then see if there is any change in RoboHelp.

               

              Cheers... Rick

              • 4. Re: Robohelp 8. Creating new topics
                martinbach Level 1

                Rick

                 

                 

                 

                I have a Dell keyboard that has a key with the Windows Logo. At what stage do you mean press the logo/P keys? With Robohelp open?

                 

                 

                 

                I tried doing that with the focus on a topic, but all that happened was that the focus moved up the hierarchy tree to the folder the topic is in.

                 

                 

                 

                I'm wondering if a Windows update has caused this. I installed a tranche last week on 11 June, which was the day after I last used Robohelp.....

                 

                 

                 

                I'm going to have to uninstall one at a time and see if this solves the problem.

                 

                 

                 

                As an aside, do you know how I can purge these add-on/plug-in updates which keep trying to install whenever I start Robohelp?

                 

                 

                 

                Regards

                 

                 

                 

                Martin

                • 5. Re: Robohelp 8. Creating new topics
                  Captiv8r Adobe Community Professional & MVP

                  Hello again

                   

                  The Windows+P key combination normally produces the following dialog:

                   

                  tmp1.png

                   

                  As it's a Windows keystroke, it shouldn't matter whether RoboHelp is in or out of focus or even open. This dialog is for switching the projection modes. What I was reaching for (and admittedly it was a stretch) was that perhaps the computer is thinking that a second monitor is the primary monitor. And by choosing to Duplicate, you could coax the hidden dialog to finally appear when you try to add or duplicate topics.

                   

                  Sorry, but I really don't have a suggestion on the add ons that are trying to install. I've seen that here and there through the years where launching assorted programs will trigger some sort of install. Most of the time, the fact the install is being triggered is more of a red herring than an issue with RoboHelp or whatever.

                   

                  Cheers... Rick

                  • 6. Re: Robohelp 8. Creating new topics
                    martinbach Level 1

                    Rick

                     

                     

                     

                    I'm using Vista, and I think that maybe your Windows/P thing is Windows 7 (or higher?)

                     

                     

                     

                    If I find that it's a Windows update that has messed Robohelp up I'll let you know. Might help others.

                     

                     

                     

                    Martin

                    • 7. Re: Robohelp 8. Creating new topics
                      Captiv8r Adobe Community Professional & MVP

                      Oh dear...

                       

                      Vista!

                      • 8. Re: Robohelp 8. Creating new topics
                        martinbach Level 1

                        Rick

                         

                         

                         

                        Actually - Oh dear.... Microsoft.

                         

                         

                         

                        It was Windows KB 3057839 that has caused the trouble.

                         

                         

                         

                        Uninstalling that has restored RoboHelp to normal behaviour.

                         

                         

                         

                        Thanks for your help!

                         

                         

                         

                        Martin