6 Replies Latest reply on Jan 4, 2007 12:37 PM by MergeThis

    TOC Missing

    Erika123
      Hi,

      I am trying to publish a robohelp project to the intranet and although my TOC is there and publishes fine when I create a chm it does not appear on the intranet. The Contents tab is there but empty. I have the TOC and Index checkbox ticked on my window description, when I work through the wizard to set up the publish I have the Contents(defualt) checkbox ticked on the toolbar buttons page.

      Any ideas as to what else I can check, is there some way to look at the output files and see what is being written, I do not know which files in the output are my TOC?

      Thanks for any help
      Erika
        • 1. Re: TOC Missing
          CraigCC Level 2
          Hi Erika,

          are you trying to run the .chm over a network/intranet rather than locally. If so, that will be your problem. Run a search on the forum and you will see a lot of post detailing this security issue. You may find it easier to use webhelp.

          Kind Regards
          Craig
          • 2. Re: TOC Missing
            Erika123 Level 1
            Craig,

            I am trying to publish the file as web help. The TOC does not appear when I publish as web help.
            If I create a chm file the TOC does appear but as you say I cannot use a chm over the intranet. This is why we are moving to the intranet version, all the other projects which I have published as web versions work fine, it is only this project which does not show the TOC in the intranet version. Any ideas why?

            Thanks
            Erika
            • 3. TOC Missing
              CraigCC Level 2
              Apologies Erica, you mentioned .chm in the orginal message which confused me.

              Does the TOC appear when you generate and view the project locally in webhelp format?
              Have you tried deleting the existing project output files completely before publishing it.

              thanks
              Craig
              • 4. Re: TOC Missing
                Peter Grainge Adobe Community Professional (Moderator)
                What is the operating system on the server? If it is unix based, could it be a case sensitive issue, I had that recently.

                • 5. Re: TOC Missing
                  Erika123 Level 1
                  Hi,

                  Thanks for the suggestions, I took a copy of the whole project, deleted the output files and tried publishing again. It still did not work :(
                  I tried recreating the project from the hhp file - still no joy
                  I ended up deleting the TOC and rebuilding it on the recreated project and finally it worked :) I have no idea what was wrong but at least it now working.

                  Thanks
                  Erika
                  • 6. Re: TOC Missing
                    MergeThis Level 4
                    It's working now because you reached the Exasperation Limit: three forum responses, 12 shrugs of the shoulders, and three slaps to the forehead.

                    Works every time.


                    Good luck,
                    Leon