5 Replies Latest reply on Jun 17, 2015 9:38 AM by Sfpamsuke

    Edge Corrupts Files When I Add Text

    Sfpamsuke

      I recently got Adobe Edge Animate CC and I am really excited to use it to add better elements to my website but I can't even go far because after I finish working with my project and save it, when I go to re-open it says there's a java error. Previewing the file in chrome leaves it blank.

       

      Through trial and error I've drawn it down to when I add text to the file. Every time I've added text, saved, and tried to re-open, the file is corrupt. I have tried deleting my preferences and re-installing but it still happens. I would absolutely love to use this program but I am seriously at my wit's end. Is this an issue in the new update or something (June 2015) or is this one of those problems where it just happens to me and I can't find a fix ANYWHERE. I checked the debug file that was automatically created and it was blank as well. Can someone please help me?

        • 1. Re: Edge Corrupts Files When I Add Text
          Sfpamsuke Level 1

          After more trial and error, I realized it has only happened after copying and pasting said text. I'd still like to know why this happens though. Could it be how the text was formatted prior somehow doing that?

          • 2. Re: Edge Corrupts Files When I Add Text
            foj Level 1

            Maybe try changing the possible-formatted text to plain text in email or a notepad (thinking Windows but sure Apple will have something similar) - see if it still happens. EA does lots of odd stuff, done some very weird stuff to me, and not too many answers around.

             

            Hope this helps, I think it's all trial and error.

            • 3. Re: Edge Corrupts Files When I Add Text
              Sfpamsuke Level 1

              I'll try that. But now I'm having another issue. In edge I'm making a slideshow and when I use the pin toggle to make the opacity change as it transitions, it works perfectly in the program and looks fine but when I view it in preview or in a browser, it doesn't show the transition, it just straight out changes the image. I'm starting to get really irritated because I tried re-doing and following the tutorial on Lynda to a T and it's not working in my project. I NEED this to work for my website... When I have autoplay on, the transition works but when it is turned off, it won't.

              • 4. Re: Edge Corrupts Files When I Add Text
                foj Level 1

                Not sure what to say, I started learning about 3 months back with Lynda.com tutorials. As say EA is a little flaky, but the Lynda tutorials are usually fairly air-tight (some older videos are not so great, I think EA changed a lot with 2014 - I stand to be corrected, but a lot of JQuery I think is no longer part of the standard EA set up **really need someone who knows to put me straight on this**).

                 

                The only thing I can suggest is if you are moving to labeled frames, try having animation key-frames slightly off-set from the label so the transition starts 1-tenth of a second down the timeline (although transitions should not be an issue), I tend to follow this practice, (gives the all the code time to run maybe!), and I never put any time-line actions at zero-time - I also had a case of a function getting called twice when it was on the same frame as a (play-from) label.
                The other time I've seen jumping/skipping content like this is with memory issues, but usually not in a local Preview In Browser view.

                Test across a range of browsers if you're not already (make another the default browser or just drag and drop the html file into the browser window).


                OK, having totally dissed EA, I've got to say 99% percent of all my fails were something stupid I'd done (or not done). I haven't seen an opacity transition not work, especially when you can see it working on the time-line - so probably a pretty useless answer really! There is a link to customer support in the "unstable animate" thread if you can't find a solution.

                 

                Hope this helps in some way =]

                • 5. Re: Edge Corrupts Files When I Add Text
                  Sfpamsuke Level 1

                  Thanks, I'll try contacting customer support. It's really hard because I can't seem to find anyone else having this issue online but I hope they can help me. I'll also try starting a bit after 0. That sounds like a good idea.