4 Replies Latest reply on Jun 18, 2015 11:54 PM by Roopavathy

    Jquery plug in conflicts

    Roopavathy Level 1

      Hello there,

       

      Here is my site link

       

      http://bhc.edu.in/TESTSITE/BHC1/

       

       

      I have designed to play backgrounds.But there is some plug in conflicts with the jquery script with accordion slider's scripts.

       

      Accordion slider's script:

      <script src="http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js"></script>

       

      Background Slide show:

      <script type="text/javascript" src="style/js/jquery-1.6.2.min.js"></script>

       

      Please help me to solve it.

       

      Thanks in advance.

        • 1. Re: Jquery plug in conflicts
          BenPleysier Adobe Community Professional & MVP

          I can't find either of the two links on the page that is linked. However, the jQuery library should be called just the once in a document. The link to Google is the later version, hence I would delete the other library.

          • 2. Re: Jquery plug in conflicts
            Roopavathy Level 1

            I commented the other library leaving the google link....but still it doesn't work.....

            • 3. Re: Jquery plug in conflicts
              BenPleysier Adobe Community Professional & MVP

              Ok, we''l do a bit of housekeeping here.

               

              The Rules (mine not necessarily yours or anybody else's)

              • keep all links to style sheets and document styling in the head section of the document
              • keep all JavaScript files at the end of the body section of the document, just above the ending body tag. We'll refer to this as the JS section.
              • make sure that jQuery is linked prior to any plugins like carousels or other sliders etc.
              • make sure that links to external JS come before document level scripts

               

              With the above rules in mind

              • move line 403 - end gridcontainer - to above the JS section
              • move all of the script files and scripts to the JS section
              • rearrange the JS section so that the links come before the document level scripts
              • lastly, make sure the the link to jquery.min.js is placed at the top of the JS section.

               

              Now it will work

              • 4. Re: Jquery plug in conflicts
                Roopavathy Level 1

                Thank you....