4 Replies Latest reply on Jan 4, 2016 11:01 AM by f-shot.de

    AMD w5100 not good enough?

    davec31596586 Level 1

      Prior to lightroom CC, I notice no problems doing work in lightroom.  Yes I know GPU acceleration was not an option is lightroom 5.  I did use my GPU in Photoshop CC (2014) and didn't notice any problems doing my work.  However, moving to lightroom CC has been a problem for me when it comes to performance.  I even removed lightroom from my pc and did a clean install and continued to have problems and then I took it a step further and wiped my entire OS drive and started from scratch.  Still, Lightroom CC seems to function noticeably  slower than lightroom 5 on the same hardware.

       

      Oddly enough, I decided to disable the GPU option in lightroom and BOOM..  she is back to running as fast as I am used to.  What gives?

      In troubleshooting, i've made sure that my computer has the lastest Window's updates, ontop of being on Lightroom CC 2015.1 [ 1025654 ], I was on the lastest version of AMD's driver for my card & for giggles, I pulled out the original driver I had from the CD included in the box.

       

      For the rest of my pc specs, I'm running a Core i7-4770k @ 4.50ghz, 32gb Ram @ DDr3 2400 Mhz, and multiple Samsung Pro SSDs, 2 sets in Raid 0.  So I know i have a fast pc. 
      Is there something I should be doing to tweak the GPU performance??

       

      Thanks in advance,

      Dave

        • 1. Re: AMD w5100 not good enough?
          ManiacJoe Adobe Community Professional

          Adobe is still working out the issues with the "version 1" GPU acceleration in LR. See these threads for details and possible workarounds:

          GPU notes for Lightroom CC (2015)

          OpenGL Failure in Lightroom CC

           

          The easy approach, as you have found, is just to turn off the GPU acceleration until some fixes come out for it.

          • 2. Re: AMD w5100 not good enough?
            davec31596586 Level 1

            Thanks Joe,

            I figured as much but I wanted to make sure that there wasn't something else I should be doing to utilize the GPU better.  I will continue to test it out as they release driver updates from AMD & software patches from Adobe.

             

            Cheers!

            • 3. Re: AMD w5100 not good enough?
              ManiacJoe Adobe Community Professional

              Since I have an old video card, which I place no faith in ever getting to work with the acceleration, I have not been keeping up with the GPU threads. However some folks in those thread have noted that reverting back to some older video drivers has worked for them.

              • 4. Re: AMD w5100 not good enough?
                f-shot.de Level 1

                Hello,

                 

                any News?

                I have some trouble with the new AMD Driver and  w5100 firepro GPU in Lightroom CC

                 

                Lightroom:

                Check OpenGL support: Failed

                Vendor: ATI Technologies Inc.

                Version: 3.3.13411 Core Profile Context FireGL 15.201.2401.0

                Renderer: AMD FirePro W5100 (FireGL V)

                LanguageVersion: 4.40

                 

                 

                PhotoshopCC No Problem:

                 

                Mit OpenGL zeichnen: Aktiviert.

                OpenGL – alte GPUs zulassen: Nicht erkannt.

                OpenGL-Zeichnungsmodus: Erweitert

                OpenGL – normalen Modus zulassen: Wahr.

                OpenGL – erweiterten Modus zulassen: Wahr.

                AIFCoreInitialized=1

                AIFOGLInitialized=1

                OGLContextCreated=1

                NumGLGPUs=1

                NumCLGPUs=1

                glgpu[0].GLVersion="3.0"

                glgpu[0].IsIntegratedGLGPU=0

                glgpu[0].GLMemoryMB=4096

                glgpu[0].GLName="AMD FirePro W5100 (FireGL V)"

                glgpu[0].GLVendor="ATI Technologies Inc."

                glgpu[0].GLVendorID=4098

                glgpu[0].GLDriverVersion="15.201.2401.0"

                glgpu[0].GLRectTextureSize=16384

                glgpu[0].GLRenderer="AMD FirePro W5100 (FireGL V)"

                glgpu[0].GLRendererID=26185

                glgpu[0].HasGLNPOTSupport=1

                glgpu[0].GLDriver="aticfx64.dll,aticfx64.dll,aticfx64.dll,amdxc64.dll,aticfx32,aticfx32,at icfx32,amdxc32,atiumd64.dll,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva, atiumd6a.cap,atitmm64.dll"

                glgpu[0].GLDriverDate="20151104000000.000000-000"

                glgpu[0].CanCompileProgramGLSL=1

                glgpu[0].GLFrameBufferOK=1

                glgpu[0].glGetString[GL_SHADING_LANGUAGE_VERSION]="4.40"

                glgpu[0].glGetProgramivARB[GL_FRAGMENT_PROGRAM_ARB][GL_MAX_PROGRAM_INSTRUCTIONS_ARB]=[2147 483647]

                glgpu[0].glGetIntegerv[GL_MAX_TEXTURE_UNITS]=[8]

                glgpu[0].glGetIntegerv[GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS]=[192]

                glgpu[0].glGetIntegerv[GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS]=[32]

                glgpu[0].glGetIntegerv[GL_MAX_TEXTURE_IMAGE_UNITS]=[32]

                glgpu[0].glGetIntegerv[GL_MAX_DRAW_BUFFERS]=[8]

                glgpu[0].glGetIntegerv[GL_MAX_VERTEX_UNIFORM_COMPONENTS]=[16384]

                glgpu[0].glGetIntegerv[GL_MAX_FRAGMENT_UNIFORM_COMPONENTS]=[16384]

                glgpu[0].glGetIntegerv[GL_MAX_VARYING_FLOATS]=[128]

                glgpu[0].glGetIntegerv[GL_MAX_VERTEX_ATTRIBS]=[16]

                glgpu[0].extension[AIF::OGL::GL_ARB_VERTEX_PROGRAM]=1

                glgpu[0].extension[AIF::OGL::GL_ARB_FRAGMENT_PROGRAM]=1

                glgpu[0].extension[AIF::OGL::GL_ARB_VERTEX_SHADER]=1

                glgpu[0].extension[AIF::OGL::GL_ARB_FRAGMENT_SHADER]=1

                glgpu[0].extension[AIF::OGL::GL_EXT_FRAMEBUFFER_OBJECT]=1

                glgpu[0].extension[AIF::OGL::GL_ARB_TEXTURE_RECTANGLE]=1

                glgpu[0].extension[AIF::OGL::GL_ARB_TEXTURE_FLOAT]=1

                glgpu[0].extension[AIF::OGL::GL_ARB_OCCLUSION_QUERY]=1

                glgpu[0].extension[AIF::OGL::GL_ARB_VERTEX_BUFFER_OBJECT]=1

                glgpu[0].extension[AIF::OGL::GL_ARB_SHADER_TEXTURE_LOD]=1

                clgpu[0].CLPlatformVersion="2.0 AMD-APP (1800.12)"

                clgpu[0].CLDeviceVersion="2.0 AMD-APP (1800.12)"

                clgpu[0].IsIntegratedCLGPU=0

                clgpu[0].CLMemoryMB=4096

                clgpu[0].CLName="Bonaire"

                clgpu[0].CLVendor="Advanced Micro Devices, Inc."

                clgpu[0].CLVendorID=4098

                clgpu[0].CLDriverVersion="1800.12 (VM)"

                clgpu[0].CUDASupported=0

                clgpu[0].CLBandwidth=7.69388e+010

                clgpu[0].CLCompute=645.647