8 Replies Latest reply on Jun 19, 2015 2:48 AM by shirleyc8970204

    Lightroom 5.7 not compatible with Mac OSX Lion?

    shirleyc8970204

      I was using LR 5.3 for my canon camera raw files. I recently got a new olympus camera and needed to edit the raw images which are .orf format. My LR 5.3 could not read these files so I updated to LR 5.7. Once installed, it prompted me that I cannot use this with my current Operating System. I am using Mac and running on OSX Lion. However reading the system requirements, it seems LR 5.7 should be fully compatible with OSX Lion. Any ideas what I am doing wrong?LR