1 Reply Latest reply on Jun 23, 2015 2:29 PM by bg21016037

    Digital Editions could not connect to the activation server.

    psyberman

      I know many people have discussed this before and I have tried all their solutions (I think ).

      OS: Vista
      ADE 4

      Up till the 16/06.15 I had no problem borrowing books from my public library for at least a year. I can't think of anything which has changed apart from the date.
      Today (20/06/15) I get the message, "Digital Editions could not connect to the activation server. Please make sure you are connected to the internet."

      ADE4.png

      • I verified I was connected to the internet
      • I rebooted
      • I made sure I was not using any proxies, VPN, etc
      • I verified my only firewall (ZoneAlarm) was allowing traffic to and from ADE
      • I turned off my firewall
      • I turned off my anti-virus (AVG)
      • I verified with Task Manager that no other stray security processes were running
      • I started ADE as Admin (suggested somewhere)
      • I unregistered and failed to re-register my desktop computer with ADE - same fault
      • I uninstalled ADE and reinstalled it
      • I tried downloading the link for the book, then opening it in ADE
      • I tried borrowing the book with my netbook (Windows 7), which worked , but of limited use to me.

      OK, I'm stuck for the next idea. I'm limited by the license terms about how inquisitive I can get, (and I can't justify the time.)
      Bright ideas anybody? Everything worked fine until today.

        • 1. Re: Digital Editions could not connect to the activation server.
          bg21016037

          Bump.

           

          I am also having this problem. Originally using 2.0, Windows 7 up until a little over a week ago when ADE said that it could no longer connect to the fulfillment server when I tried to return books so tried to deauthorize and reinstall, which yielded the Connection Error - Digital Editions... message. Authorizing with Windows firewalls completely down (exception didn't work) makes it go through to the authorizing step with the flashing green bar and the Please wait while your computer is being authorized, but it just keeps on flashing without ever going through. Tried 4.03 for an hour, uninstalled, restarted, tried with 2.0 and same thing.

           

          The only thing that has changed recently in the computer environment is the installation of the Windows updates released this month.