4 Replies Latest reply on Jun 23, 2015 2:40 AM by ksporry

    Incorrect renaming of files during export from Lightroom

    ksporry

      Today I tried exporting a batch of 3 files from Lightroom CC, with a rule to be rename the files "custom name - original file name". The first of the three in the batch was renamed correctly during export. The other two were not renamed in accordance with that rule, and instead only showed "custom name -.jpg". Why is that? What could cause that?

      Couple of notes:

      1. This was consistent behaviour. I tried several times with the exact same result.
      2. I did not have this happen to me before.
      3. I tried exporting each file individually, but the behaviour did not go away. 2 files were still incorrectly named.
      4. When I hover the mouse pointer over the file in Lightroom, or select the file in LR, the correct filename shows up normally, so it's not that the file is named differently from what I think it is. Also the directory shows the correct filename.

      I'm suspecting it may be related to renaming in PS after editing them in PS. Basically, all three were edited in PS, 1 was saved with the original filename, 2 got renamed with a suffix ("-PS") when I saved them in PS. I had to add the renamed ones back into LR manually (which seems consistent with what I read about how LR handles files edited and saved from PS).  The one that wasn't renamed exported correctly from LR. The other two did not.

        • 1. Re: Incorrect renaming of files during export from Lightroom
          99jon Adobe Community Professional & MVP

          Do the file names have any symbols from the  illegal character list. You can check your settings by going to:

          Edit >> Preferences >> File Handling (tab)

           

          Lightroom >> Preferences >> File Handling (tab) on Mac OSX

           

          Also do they contain an extra period e.g. IMG_1234.NewYork.tif

          • 2. Re: Incorrect renaming of files during export from Lightroom
            ksporry Level 1

            yep, file names do not contain illegal characters. The filenames are John-1234567 (correct sample), John-12344567-PS and John-8901234-PS. Last two files are originally PSD files, the first file is a 3FR file (RAW for Hasselblad).

            • 3. Re: Incorrect renaming of files during export from Lightroom
              99jon Adobe Community Professional & MVP

              I think the problem is using original file number as the EXIF will be different to the file name saved in Photoshop.

               

              In the export dialog click to the right of Rename to: (on the dropdown word custom settings) and choose Edit

               

              In the template editor clear the existing fields choose Custom Name and click the insert button. Next choose Filename and click the insert button.

               

              See image below. I’ve used the custom name London as an example in the export dialog. See if that works.

               

              FileTemplateEditor.png

              • 4. Re: Incorrect renaming of files during export from Lightroom
                ksporry Level 1

                Actually, I just played with that. I selected custom (insert) and then Filename (insert), and saved it as a preset. Then I went back to the main export, I actually selected (by accident) Custom Settings, instead of the new preset. Tried again, and it exported correctly for all files in the batch. Interesting how that worked. I see some opportunities for preset export settings (e.g. for facebook, 500PX, FLickr, and for other applications the export settings could be completely different).