11 Replies Latest reply on May 22, 2007 10:13 PM by cegie

    Adding my language to the recording options

    cegie Level 1
      Hi,
      i've try to do that , but it not working.
      I've try to insert my own files to Macromedia Capivate and Adobe Captivate 2 - new files (CaptureTextTemplates_Polish.rdl) are not visible on Language list.
      Have You got any ideas to fix it?
      Regards
      Czarek
        • 1. Re: Adding my language to the recording options
          Hal_2001 Level 1
          Have you followed each step in the 5 pages on the TechNote? The link you included went only to the 5th of 5 pages ...
          • 2. Re: Adding my language to the recording options
            cegie Level 1
            Yes, I followed each steps from 1 till 5 page.
            And first:
            I've do what I've read in all steps
            And the second:
            I've rename the ..._German.rdl to ..._Polish.rdl and the new file wasn't appear on the language list.

            I think I must insert some information about new language, but where?
            But the other way, if I remove ..._German.rdl file they not appears on the list...so, it is not right way to solve this issue, am I right? What do You think? Any other suggestions?
            PS
            I've post my message to Fabricio Manzi and still waiting for his answer...

            Regards
            Czarek
            • 3. Re: Adding my language to the recording options
              Captiv8r Adobe Community Professional & MVP
              HI Czarek

              Hopefully Hal won't mind my offering some insight here. Personally, I believe that article wasn't fully researched. I don't believe this will work for any language. It does work for Portugese, and to my knowledge it is the *ONLY* additional language it will work for.

              You are probably wondering why.

              This is just a hunch on my behalf, but I think Portugese was simply overlooked in the possible language choices when Captivate was first created. It existed in RoboDemo 5, but not Captivate. As it was once there, the application knew to look for it. So all one had to do was to create the missing .RDL file in order to see Portugese magickally pop into the list of choices. But as you have seen, this fails if you use any language other than Portugese.

              The workaround? Repurpose one of the other existing language files. Perhaps German or Chinese. Yes, it may be listed as German or Chinese, but if selected would reflect your desired language.

              Oh, and definitely report it via the WishForm/Bug Report.

              Cheers... Rick
              • 4. Re: Adding my language to the recording options
                Hal_2001 Level 1
                Czarek, you said...
                quote:

                I've post my message to Fabricio Manzi and still waiting for his answer...
                I am a sucker for pop quizzes and trivia ...

                WHO is Fabricio Manzi?

                (I bet I'm going to be sorry I asked)
                • 5. Re: Adding my language to the recording options
                  Captiv8r Adobe Community Professional & MVP
                  Hi Hal

                  Fabricio Manzi is the person that incorrectly suggested in his Developer Center article (the one Czarek cited) that any ole language you want can just be plopped into the list of languages for Captivate and they magickally appear in the drop-down list!

                  Cheers... Rick
                  • 6. Re: Adding my language to the recording options
                    cegie Level 1
                    Hi,
                    thanks - I hope You will answer me quickly as You can.
                    I'll do what You suggesting

                    Thanks again
                    Czarek
                    • 7. Re: Adding my language to the recording options
                      Silke Fleischer Level 1
                      This is my mistake - I was under the assumption you can add any language and worked with Fabricio on the article. He did a wonderful job with the article and I told him this would work with all languages (that's what I thought until now).
                      Looks like you can only add Portuguese and Dutch, which were languages supported in RoboDemo 4 in addition to the current set. Due to limited localization resources, we had to drop those two files in RoboDemo 5.
                      As a workaround, you could create the Polish file, but you would need to use a "pseudo" name for the file and call it Dutch, or Portuguese, or any of the file names of languages you are not using. I sent the issue to the team and I hope we can fix it for Adobe Captivate 3 but I might have found out too late in the dev cycle. We now at least know for Adobe Captivate 4.
                      • 8. Re: Adding my language to the recording options
                        cegie Level 1
                        Hi, Silke
                        Thanks for Your answer.
                        What I did? I wrote Polish language file myself an replace an original German file with my file So, it's still working. After few days I send it to the Captiv8er to place it in a new version of the Captivate. Please, check it out.
                        Thanks again
                        Czarek
                        • 9. Re: Adding my language to the recording options
                          Captiv8r Adobe Community Professional & MVP
                          Hi Czarek

                          You said: After few days I send it to the Captiv8er to place it in a new version of the Captivate.

                          This makes me think that you possibly believe I'm an Adobe employee. While I'd be more than happy to do whatever I could with the file, I'm just a Captivate user same as you. Actually, Silke would be the wiser choice of recipients here, as she is an official Adobe employee and is much closer to the developers than I am.

                          Sincerely... Rick
                          • 10. Re: Adding my language to the recording options
                            Silke Fleischer Level 1
                            :) Rick, why don't you shoot me the file and I'll see what I can do (No promises here but you never know what's possible unless you try).
                            • 11. Re: Adding my language to the recording options
                              cegie Level 1
                              Ups, sorry for my mistake...
                              It means, You are freelancer? Ok, but if You are ordinary Captivate user, You are very smart user.
                              Greetings
                              Czarek