14 Replies Latest reply on Jul 25, 2007 1:52 AM by RoboColum(n)

    Conditional Build Tags in Table

    Holly67
      I have a table with three rows (in the middle of the table) that are conditional tags. When I generate the Webhelp output for the version that excludes the tagged rows, I end up with blank lines in the table where the tagged rows were omitted. How do I get rid of these blank lines?

      Thanks for any help/suggestions.
        • 1. Re: Conditional Build Tags in Table
          RoboWizard Level 4
          Hi Holly67 and welcome to our community

          For this one, you will need to sneak behind the scenes and work some with the TrueCode. When you do this, note the styling information added to the content with the tag. Your goal is to copy this information and insert it where you see the <TR> tag. So instead of seeing <tr valign=top>, you see <tr valign=top style="x-condition: ConditionName;">. Of course, ConditionName should reflect the name of the Conditional Build Tag you are using.

          Hope this helps... Rick
          • 2. Re: Conditional Build Tags in Table
            Holly67 Level 1
            That worked! Thanks :)
            One additional hint to others who are having the same problem.... Once you move the x-condition info to the top <tr, remove all other duplicate x-condition info. (RoboHelp automatically inserted x-condition info in each column in the row.) Otherwise, you'll still have blank lines.
            • 3. Re: Conditional Build Tags in Table
              tswaters1
              Boy what a pain in the ***

              I ran into this same problem, I've got these table layouts for an Online User Guide and wanted to apply conditional build tags to exclude from the printed version -- except I ran into HARD CRASHES when trying to apply them to the whole table. I'm not entirely sure why -- may have been the floating images inside some cells, or nested tables or col/rowspan or something. either way, pain in the ***.

              my end solution is basically go into True Code, find '<tr style="' replce with '<tr style="x-condition: Online;'........... fortunately there's only ever one table on any given topic.
              • 4. Re: Conditional Build Tags in Table
                MergeThis Level 4
                tswaters1:

                I fail to see how your practice of creating tables full of "floating images inside some cells, or nested tables or col/rowspan or something" is reason to come in here and loudly proclaim your disgust, especially when the solution has been provided (to the original poster, Holly67). Having created online help since 1987 (DEC Bookreader), I've learned to work defensively. That is, the more complex you make things, the more things can go wrong (just because you can get fancy, doesn't mean you should!).

                A little civility goes a long way. After all, participation in this user forum is voluntary, and performed in addition to the participants' real jobs.


                Good luck,
                Leon
                • 5. Re: Conditional Build Tags in Table
                  HKabaker Level 2
                  Holly and ts,

                  Are you using RH x5.2? I think it's fixed in RH6. Please post back if I'm wrong.

                  Harvey
                  • 6. Re: Conditional Build Tags in Table
                    Peter Grainge Adobe Community Professional (Moderator)
                    This was fixed in RH6.
                    • 7. Re: Conditional Build Tags in Table
                      clauatos
                      I'm have problems with this conditional build tags. I create a new tag, apply this for a one TOC or a topic. After that I describe a expression (NOT TAG1), when I compile to generate a primary view of the project , an error occured and close my project and the RoboHelp. If I return the expression for NONE , the compilation occured normaly. Someone knows what can I do to resolve this problem?? Thanks!!!
                      • 8. Re: Conditional Build Tags in Table
                        RoboColum(n) Level 5
                        Hi clauatos and welcome to the RH community. Can you provide with some more information please? What version of RH are you using (e.g. X5)? Are your project source files on a network drive? Have you tried creating a new project and seeing if the same problem occurs?
                        • 9. Re: Conditional Build Tags in Table
                          clauatos Level 1
                          Thanks! I'm using the RH 6. I already did a new project and I saw that its works normally, must the problem is in my project, but I don't know how resolve this, please help me.
                          My project is on a network drive, they are controlled by versions (the name is Subversion Tortoise , if you still hear about it).

                          Thanks!!
                          • 10. Re: Conditional Build Tags in Table
                            HKabaker Level 2
                            Clauatos,

                            I agree, these are the most likely places to look first for RH X5.

                            Colum,
                            Probably you have this in mind already:

                            RH 6 needs the updated dll to fix the bug related to build tags and merged cells in tables.

                            Harvey
                            • 11. Re: Conditional Build Tags in Table
                              clauatos Level 1
                              So, I need update some dll. How can I do that?
                              • 12. Re: Conditional Build Tags in Table
                                Captiv8r Adobe Community Professional & MVP
                                Hi clauatos

                                Take a look at Snippet number 71 (near the top) at the following link: click here

                                Cheers... Rick
                                • 13. Re: Conditional Build Tags in Table
                                  clauatos Level 1
                                  Hey people... I'm much thankful for help.. The problem was resolved when I replaced the dll.

                                  I'm starting to work with RoboHelp now... so do you know if existis a way of my software show the Help depending a user choice? Where can I read about that?

                                  Thanks everybody for all..
                                  • 14. Re: Conditional Build Tags in Table
                                    RoboColum(n) Level 5
                                    Are you saying that you want a way of displaying a particular help file depending on a user's configuration? For example user 1 displays help file A but users 2 & 3 display help file B? If so, this is technically possible but is way beyond my area of expertise. As an author you would use the conditional build tag feature in RH to include/exclude the content for the two help files. Once you have this it is possible for the application to check licence settings and display the appropriate help file. This has been discussed in the past on these forums so if you search back you will find similar questions. Best of luck.