1 Reply Latest reply on Jul 7, 2015 3:54 PM by kawikaheftel

    itunesconnect

    nasers48644153 Level 1

      Hi Every one.

      Thank you in Advance.

      I developed app and uploaded to Google Play. It is working perfect.

      Same application .. i generated licences from developer.apple.com and followed all rules to export *.api file.

       

      I login to Mac .. download Application Loader and tried to upload file. I got long error and warning . I am developing application in flash builder 4.6 but message is saying to use xcode... Please can any one help

       

      ------------------------------------------------------------------------------------------ -------------------------

      Here is error.

      your app is built with a beta version of xcode or ios sdk. Only app distributed for beta testing may be builtl

       

      missing recommended icon file. bundle does not contain an app icon for ipad or exactly 76x76 pixels,

       

      missing reccommended icon file. the bundle does not contain an app icon for ipage 152x152

       

      iphone / ipod touch of exactly 120x120

       

      Error itms-90096... your binary is not optimized for iphone 5 - news app updates submitted must support 4-inch display on iphone 5

      error itms-90096 your binary is not optimized for iphone 5 - n

      error items-90086: " missing 64-bit support, beginning on february 1, 2015 new iOS apps submitted to the App Store must include 64-bit support and be built with ios 8sdk

       

      Error itms-90022: " Missing required icon file. The bundle does not contain an app icon for iphone / ipod touch of exactly 57x57 pixels in .png formate for ios version< 7.0

       

      ------------------------------------------------------------------------------------------ ----------------------------------------------------

      Thanks.

      Naser

        • 1. Re: itunesconnect
          kawikaheftel Level 3

          regarding the icons - make sure you have icons included at those sizes

           

          regarding "not optimized for iphone 5" - you need an iphone 5-specific launch images (Default-568h@2x.png, 640x1136)

           

          regarding 64-bit and beta version of sdk - what AIR SDK version are you using?