4 Replies Latest reply on Jul 9, 2015 9:29 PM by Greg Grosz

    Why photos added to LR do not appear in LR?

    Greg Grosz Level 1

      I'm using a Mac Pro 3.1, OS 10.6.8, LR CS6 (4.4).

      I scanned hundreds of negatives into a folder, then Imported them into LR by Adding them.  At first all my photos appeared in LR but now many photos do not appear.  I tried Adding them again using LR Import with the "Do not add duplicates" box checked.  LR seems to know that the photos already have been added to the catalog because LR won't import them again.  The photos are visible in the Finder folder but not the folder in LR even though I added them and saw them there previously.

       

      Has anyone had a similar problem?  Is it possible that my Catalog became corrupted?  I'm aware that LR will not recognize photos that have been moved around outside of LR, so I have been very careful in that regard.

       

      Greg

        • 1. Re: Why photos added to LR do not appear in LR?
          dj_paige Level 9

          Follow these steps

           

          1. Go to the Library module, on the left, in the Catalog section, click on "All Photographs"
          2. Then, Library->Enable Filters should not have a check next to it
          3. Expand All Stacks (Photo->Stacking->Expand all Stacks)
          4. Search for one of these photos by file name, and you will find it.

           

          Once you find it, you either need to make a note of its location, or organize them to your liking so you don't have to go through this procedure to find them again.

          • 2. Re: Why photos added to LR do not appear in LR?
            Greg Grosz Level 1

            Thanks for your reply.

             

            The issue is that the photos ARE in the correct folder when I look on the Desktop (Finder), and I've already Imported them into PS by ADDING them.  I believe they appeared there at one time, but now various ones, seemingly randomly, do not appear in that folder in PS, nor can I find them by searching All Photographs in PS.  That's why I wonder if somehow my catalog is corrupted or something else happened.

             

            Your suggestion would work if the photo was misplaced in a folder somewhere in PS, but it isn't in PS at all, even though at one point they were in PS when I Added them via Import.  If I try to Import a missing one, PS won't let me if I have "Don't Import Suspect Duplicates" checked.  This is a real conundrum.

             

            I do have over 36,000 photos in my Catalog, I wonder if that is causing strange occurrences like this?

             

            Greg

            • 3. Re: Why photos added to LR do not appear in LR?
              dj_paige Level 9

              The issue is that the photos ARE in the correct folder when I look on the Desktop (Finder), and I've already Imported them into PS by ADDING them.  I believe they appeared there at one time, but now various ones, seemingly randomly, do not appear in that folder in PS, nor can I find them by searching All Photographs in PS.  That's why I wonder if somehow my catalog is corrupted or something else happened.

              I'm not sure why you are talking about PS here. I will assume you mean Lightroom. I'm not aware of a corrupted catalog causing this issue, more likely a corrupted catalog would simply fail to open.

               

              However, just so I can understand exactly what you did, you state you can't find them by searching All Photographs. The instructions I gave included three steps before you do the search, not just going to All Photographs. Did you do all three steps? Also, did you search by file name using the Filter Bar?

              • 4. Re: Why photos added to LR do not appear in LR?
                Greg Grosz Level 1

                Yes, I mean LR.  I did go through all the steps you suggested and also searched in the Filter Bar and get no hits.  The photos appear in the same folder when viewed in the Finder and I can open them from the Finder in PS or Preview.  They do not appear in that folder in the stack of folders in LR.

                 

                I would understand it if I had failed to Add the photos to the LR Catalog properly, but I did Add them and they did appear in the LR folder a month or so ago.  Most of the photos are in the LR folder but some seem to have disappeared.  LR seems to think they are in LR because they aren't checked for Import when I try to import them again with the "Don't Import Suspect Duplicates" box checked.