1 Reply Latest reply on Jul 16, 2015 9:05 AM by LizWilson

    Windows extension manager fails due to signing problems

    LizWilson Level 1

      I develop an InDesign plugin which supports versions from CS5.5 up to CC2014 on both Mac and Windows, installed with a zxp in Extension Manager.

       

      While working on support for CC2015, for some reason the zxp now won't install on any versions on Windows through Extension Manager.

       

      There have been minor code changes since it last worked (no new files with special characters as in Extension Manager CC failed to install extension) and the addition of CC2015 plugin files. Excluding the 2015 files from the zxp doesn't fix it.

       

      The p12 is still valid and the same zxp installs on Mac fine for all supported versions (except 2015 but that's expected)

       

      I've tried it with and without a timestamp in the ucf.jar command with the same results.

       

      In the log file I get:

       

      [Error] Mon Jul 13 16:27:57.072 2015 (SignatureValidator.cpp, 105) -CSignatureValidator::verifySignature: ZXPSign_verify() failed for "C:\ProgramData\Adobe\Extension Manager CC\Temp\TMP_20150713162640457", sign_status is 50!

      [Error] Mon Jul 13 16:27:57.105 2015 (ExtensionBase.cpp, 170) -CExtensionManager::validateExtension: CSignatureValidator::verifySignature() failed for "C:\ProgramData\Adobe\Extension Manager CC\Temp\TMP_20150713162640457", status is -402!

      [Error] Mon Jul 13 16:27:57.131 2015 (ExtensionBase.cpp, 607) -CExtensionBase::install: validateExtension() failed for zxp C:\Users\******\Desktop\myExtension.zxp, status = -402!

       

       

      Any ideas why this is suddenly failing?

      Thanks

        • 1. Re: Windows extension manager fails due to signing problems
          LizWilson Level 1

          Found the problem - posting solution here in case it helps anyone else!

           

          Since packaging the previous version which worked, I had had a source control cleanup, resulting in the presence of hidden .gitignore files in order to maintain a fixed empty folder structure in git into which I placed my plugin files when ready to package them.

          These hidden files were causing the signing to be rejected on Windows, but accepted on Mac.

           

          When running ZXPSignCmd -verify on the zxp file, Mac reported it as valid, while Windows reported "Failed to verify signature. Signature might have been tampered with", leading to the solution on this post: Trying to make ZXP, selfsigned certificate not valid


          Creating a "clean" version of my folder structure without the hidden files and packaging that was successful. Now installing fine across the board.