7 Replies Latest reply on Dec 22, 2006 7:19 AM by arunbe

    imported JPEG causes ptroblems when publishing

    Level 7
      Still have problems with publishing a FLA with an imported JPEG as a
      background.
      It is published OK several times and then on athe next attempt to publish it
      slows down and throws a message that the computer run out of virtual memory
      and will take it from some other processes. This takes a couple of minutes
      nd then the resulting SWF is about 10 times the size it was before and shows
      no backgrownd.
      The JPEG is still in the FLA, but it is empty.
      I delete is completely, import again - same story - compiles well only
      several first times.
      Tries it with other JPEGs - same result.
      Without JPEG thisfla compiles without problems
      The JPEG in question is a photo taken by low resolution digital camera, 1276
      by 958 pixel and 330 K


        • 1. Re: imported JPEG causes ptroblems when publishing
          Devendran Level 1
          Can u pls share the Image? to view....
          This will happen only when the File size is more.....

          if u wish to increase the virtual memory
          RightClick on the MyComputer select properties
          Now Select "Advanced"
          and set Performance Settings..... As u wish ....
          • 2. Re: imported JPEG causes ptroblems when publishing
            Marghoob Suleman Level 1
            330 k is not a big size... are you doing some animtion on this image?
            • 3. Re: imported JPEG causes ptroblems when publishing
              Level 7
              Thanks, Devendran"
              The image in question is here:
              www.andrei.plus.com/bg1.jpg

              As to increase the virtual memory - this way I will treat a symptom rather
              than a cause. This file should not require an increase of the virtual memory

              "Devendran" <devendran_be@yahoo.com> wrote in message
              news:emggdf$pj2$1@forums.macromedia.com...
              > Can u pls share the Image? to view....
              > This will happen only when the File size is more.....
              >
              > if u wish to increase the virtual memory
              > RightClick on the MyComputer select properties
              > Now Select "Advanced"
              > and set Performance Settings..... As u wish ....
              >
              >


              • 4. Re: imported JPEG causes ptroblems when publishing
                Level 7
                Thanks, Marghoob Sulemaan

                No animation. The picture is used as a still background
                It is imported to the library. Then it is placed into a movieclip.
                This movieclip is then positioned in place using attachMovie(), _x,_y,
                _xscale and _yscale properties


                "Marghoob Sulemaan" <webforumsuser@macromedia.com> wrote in message
                news:emghvj$r4k$1@forums.macromedia.com...
                > 330 k is not a big size... are you doing some animtion on this image?


                • 5. Re: imported JPEG causes ptroblems when publishing
                  arunbe Level 1
                  Its somewhat a difficult problem, i never met before.
                  But, I need some more details.
                  May i know whats the file size of your main fla file in which you are importing the image ??? And what version you are using now ????
                  Onething is sure, its only due to the upnormal file size.
                  Check it out....
                  • 6. Re: imported JPEG causes ptroblems when publishing
                    Level 7
                    The size of main fla file in which I am importing the image is 2.5Mb
                    Version of Flash is 8, AS version 2
                    I cannnot see file size abnormality here.
                    The most puzzling is that after I remove and re-import the image it compiles
                    well several times? before the problem repeats. It looks like something is
                    accumulationg over repeated publishing.
                    Or my code might have some hidden side effect which does something with the
                    image

                    "arunbe" <fresharunbe@yahoo.com> wrote in message
                    news:emgpb5$601$1@forums.macromedia.com...
                    > Its somewhat a difficult problem, i never met before.
                    > But, I need some more details.
                    > May i know whats the file size of your main fla file in which you are
                    > importing the image ??? And what version you are using now ????
                    > Onething is sure, its only due to the upnormal file size.
                    > Check it out....
                    >


                    • 7. Re: imported JPEG causes ptroblems when publishing
                      arunbe Level 1
                      Ok, Community experts may take a look into it.
                      Instead of that, i wil give you another idea.
                      Dont publish them by using "Ctrl+Enter", Instead, use
                      the hidden publishing by pressing "Ctrl+Shift+F12" and check the swf file in the location. So, it may help to avoid this problem.