1 Reply Latest reply on Jul 16, 2015 4:11 AM by F. McLion

    I need to download lightroom for my mac, but says me can´t because the platform is not supported. Why is that ?

    mateor41810688

      I need to download lightroom for my mac, but says me can´t because the platform is not supported. Why is that ?