1 Reply Latest reply on Nov 29, 2016 11:58 PM by g.bollmann

    Deactivate Symbols in MainTimeline via Actions in symbols An_CC_2015

    10hofnarr01

      Hi guys,

       

      I am creating a web-tutorial which will be complex in Edge Animate CC 2015.

       

      i have a navigationbar on the left which is on top.

      then i have several categories.

      every category starts in the main timeline at 0:00:000

      and for easy adding new categories, i made every category to be a symbol.

       

      so i have

       

      -Navigationbar

      -Category 1

      -Category 2

      -Category 3

      -Category 4

      ...

       

      as layers on my stage.

       

      But:

      Every category uses full size of stage,

      so if I am in category 2 i can't press any button becase category 1 is still active...

       

       

      how to deactivate the categories if i play the symbols?

       

       

      i tried to create a new order of the layers via z-index.

       

      so after starting another category the actual category is on top...

      didn't worked...

       

      Used this code:

       

      (this is in the symbol after playing about 100ms)

      sym.$("_Erster_Start").css({"Z-index":-520});

      sym.$("_Apps_Sperren").css({"Z-index":510});

      sym.$("_Nachtsperre").css({"Z-index":-530});

      sym.$("_Ferienmodus").css({"Z-index":-540});

      sym.$("_Sicheres_Surfen").css({"Z-index":-550});

      sym.$("_System_Berechtigungen").css({"Z-index":-560});

      sym.$("_Nutzungsstatistiken").css({"Z-index":-570});

      sym.$("_Schutz_Verlaengern").css({"Z-index":-580});

      sym.$("_Freunde_Werben").css({"Z-index":-590});

      sym.$("_Account_Verwalten").css({"Z-index":-600});

      sym.$("_PW_Vergessen").css({"Z-index":-610});

      sym.$("_PYK_Neu_Einstellen").css({"Z-index":-620});

      sym.$("_Problem_Melden").css({"Z-index":-630});

       

      didn't work...

       

       

      then i thought to disable the other symbols using display:none;

       

      sym.$("_Erster_Start").css({display:none});

      sym.$("_Apps_Sperren").css({"Z-index":510});

      sym.$("_Nachtsperre").css({display:none});

      sym.$("_Ferienmodus").css({display:none});

      sym.$("_Sicheres_Surfen").css({display:none});

      sym.$("_System_Berechtigungen").css({display:none});

      sym.$("_Nutzungsstatistiken").css({display:none});

      sym.$("_Schutz_Verlaengern").css({display:none});

      sym.$("_Freunde_Werben").css({display:none});

      sym.$("_Account_Verwalten").css({display:none});

      sym.$("_PW_Vergessen").css({display:none});

      sym.$("_PYK_Neu_Einstellen").css({display:none});

      sym.$("_Problem_Melden").css({display:none});

       

       

      didn't work as well...

       

      _Erster_Start is still active on top  and i can't use my buttons to move to the next step in _Apps_Sperren.