3 Replies Latest reply on May 8, 2006 8:59 PM by kglad

    LoadMovie and LoadClip  - Interactions are dissapearing!

      Hi,

      I've been working on this problem for a couple of days but can't seem to find a way around it. I'd appreciate any help!

      Basically, I have a swf file which contains a small slideshow, simply 5 buttons along the bottom that flick between 5 different main pictures all inside the swf. I'm trying to load this swf into a larger application so that it displays on the centre of the page. I have tried the simple LoadMovie code as follows:

      this.createEmptyMovieClip("slideshow", 1);
      loadMovie("slideMy.swf", slideshow);

      slideshow._x = 200;
      slideshow._y = 200;

      and this loads in the swf but the buttons will not work at all. I can see the swf but can't interact with it. When you move the pointer over the buttons the mouse pointer does change to the hand to acknowledge it's clickable but on clicking nothing happens.

      In an attempt to get it to work I tried using the following method:


      var myMCL:MovieClipLoader = new MovieClipLoader();
      var myListener:Object = new Object();

      myMCL.addListener(myListener);
      myMCL.loadClip("slideMy.swf", 5);


      and this loads in the swf perfectly, the buttons all function no problem at all, but I can't figure out how to reposition the swf in this manner as it's not loaded into a movie clip. I've tried _level5._x = 100 but this doesn't seem to affect it at all. I also tried loading into a movieclip using this method, replacing the 5 with an instance name, but again the buttons stop working.

      So basically, i have two questions... Firstly, why are my buttons refusing to work when loaded into a movieclip? And secondly, is there any way to reposition a swf when it's loaded in using the second method. Any help would be greatly appreciated, it's driving me crazy!

      Colin.