5 Replies Latest reply on Aug 6, 2015 12:20 PM by Steve Werner

    Is there a way to disable GPU use in InDesign?

    AJDesignCo Level 1

      I'm using InDesign 2015.0, 11.0.1.105 Build on a 2015 MacBook Pro 15" with Retina Display.


      When I launch ID, my system switches to the AMD Radeon graphics card. When I quit ID, my system flips back to the Intel Iris Pro graphics card.


      Is there a way to disable whatever is forcing the Radeon card to be used? I'm trying to manage my really puny battery life on this new system. Thanks in advance for any insight and tips!

        • 1. Re: Is there a way to disable GPU use in InDesign?
          Steve Werner Adobe Community Professional & MVP

          InDesign CC 2015, unlike Illustrator CC 2015 and Photoshop CC 2015, doesn't make use of a graphics card.

           

          I don't know what's happening on your computer but there are no controls in InDesign for a graphics card at this time.

          • 2. Re: Is there a way to disable GPU use in InDesign?
            AJDesignCo Level 1

            Thanks for your reply. I guess I'm operating from incorrect information and I gave incomplete information about my system. Here's the rest of the story. I have a menu bar app called gfxCardStatus that tells me when my system is using which graphics card. When I launch InDesign, I get the notification that the AMD Radeon card is in use. When I attempt to use gfxCardStatus to force the system to switch to the Intel Iris Pro integrated card, I see this notification:

            cant-switch.jpg

            Here is the "Why?" from the gfxCardStatus app developer:

            https://gfx.io/switching.html#integrated-only-mode-limitations

             

            So apparently this app thinks InDesign is using the AMD Radeon card. And my battery life seems to agree that the AMD card is running. I get about 2.5 hours on a full charge on this brand new MacBook Pro.

             

            Does that extra information help? Is there any way I can make InDesign stop switching to the discrete card and use the integrated card? I would like better battery life, even if I sacrifice some display quality.

            • 3. Re: Is there a way to disable GPU use in InDesign?
              Peter Spier Most Valuable Participant (Moderator)

              Have you tried disabling the radeon card through the OS system configuration options?

              • 4. Re: Is there a way to disable GPU use in InDesign?
                Gaurki

                Whatever is intended or specified, Indesign CC 2015 definitely seems to be using the graphics card, at least on certain Macs.

                 

                I have an iMac with AMD Radeon HD 6970M and Intel Iris. Since upgrading to CC 2015 I am seeing visual effects in InDesign which mimic what happens in Illustrator when I have GPU Previewing enabled.

                 

                • Certain vector shapes with image fills are not anti aliased

                • Overprint Preview takes exceptionally long to load, sometimes keeps a few images at low resolution even though links are working

                • Small lines sometimes disappear entirely

                • Some small text disappears, displays oddly, or has no anti aliasing

                • Small shapes and lines inconsistently located (i.e, two images placed at the same place Y coordinate seem slightly dislocated depending on zoom level)

                • White lines appearing / disappearing on pages with changes to viewing quality and zoom level

                 

                I switch to CPU previewing in Illustrator to fix these types of glitches, need that option in Indesign fast. I need my WYSIWYG design software back!

                • 5. Re: Is there a way to disable GPU use in InDesign?
                  Steve Werner Adobe Community Professional & MVP

                  The thread below implies that InDesign can use the GPU. But clearly there are no controls in InDesign for using it:

                   

                  Indesign CC GPU Advice...