13 Replies Latest reply on Nov 10, 2015 7:03 AM by Szalam

    Audio Preview and Audio Playback Issues in CC 2015

    hpwg234

      Hello,

       

      I'm working in a 1080 25fps Sequence with 48kHz Wav files.

       

      In CS6/CC:

       

      • On the timeline I could tap '.', and it would give me an audio preview almost instantly.

      • When RAM previewing by tapping ' Numeric 0', it would play the video and audio together seamlessly.

      • Once RAM previewed, I could then slide (only the) audio layers along the timeline, and tap 'Numeric 0', the RAM preview would play instantly.

       

      2015.0.1 :

      • When I tap '.' on the timeline, there is now substantial (5 - 15 seconds) lag before it starts previewing my audio.

      When RAM previewing by tapping 'Numeric 0', on the first and second play through of the RAM preview (when it's all green and plays in realtime), the audio stutters, then play seamlessly for a few loops, then starts to stutter again.

      • Once RAM previewed, when I now slide only the audio layers along the timeline, and tap 'Numeric 0', it has to render everything from scratch, despite only the audio moving.

       

      I know After Effects has never been great with audio, but previous versions have worked just fine for me, as outline above.

       

      So my question is; is this a new bug, a side effect of the new 'preview' feature, or my dated machine finally clashing with the latest and greatest software?

       

      Thank you

       

      After Effects CC 2015.0.1

      Mac OS X 10.10.2

      Mac Pro (2008)

      16GB Ram

      2 x 3.2 GHz Quad Core

      ATI Radeon HD 5870 1024mb

        • 1. Re: Audio Preview and Audio Playback Issues in CC 2015
          Dave LaRonde Level 6

          If you haven't gotten the AE CC 2015 bug fix that came out a few days ago, get it and see if it helps.

           

          Oh, and if you haven't read up on the new previewing techniques, you should.

           

          Oh, and here's some cheery news -- they found bugs in the bug fix!  They concern rendering video files w/audio.  Don't have all the details.......

          • 2. Re: Audio Preview and Audio Playback Issues in CC 2015
            hpwg234 Level 1

            Unfortunately I have already updated (see specs at end of post), and have read about the new preview ("RAM preview is dead"). I'm not a fan (yet), but I'm sure many are.

             

            Thanks for the response.

            • 3. Re: Audio Preview and Audio Playback Issues in CC 2015
              Szalam Adobe Community Professional & MVP

              Have you considered updating your OS? In 10.10.4 Apple fixed some major bugs that affected Dynamic Link and some other AE issues.

              • 4. Re: Audio Preview and Audio Playback Issues in CC 2015
                hpwg234 Level 1

                Still having issues with the audio after 10.10.4 as mentioned above.

                • 5. Re: Audio Preview and Audio Playback Issues in CC 2015
                  Szalam Adobe Community Professional & MVP

                  Well, darn. I had hopes that would fix it for you!

                  I guess you're just bumping into some more bugs in AE's new architecture. If it's too much for you, you can continue to use CC 2014 or even older versions: How to Find and Install Previous Version of Adobe Apps in CC 2015 | Adobe Customer Care Team That's one of the nice things about the Creative Cloud; downloading previous versions can be very useful.

                  If you have time, please file a bug report on your audio issues in AE CC 2015 and give Adobe as much technical detail as possible. There is an update coming out this autumn, if I remember correctly, and I'm sure we'd all like it to be as bug-free as possible! Feature Request/Bug Report Form

                  • 6. Re: Audio Preview and Audio Playback Issues in CC 2015
                    LS3T Level 1

                    I have the same problem here. The audio preview in CC2015 is awfull (don't start à the beginning of the preview, blank cut in the middle) and there is some difficulties to synchronize audio to video (the preview is not the same thing that the render).

                     

                    Clearly, After Effects 2015 is not ready.

                    • 7. Re: Audio Preview and Audio Playback Issues in CC 2015
                      alphanine Level 1

                      Same Problem here, uninterpreted playback is the worst thing happened to AE, they should gave us the choice to enable it or not!


                      PLUS After effects 2015 now (After the latest update) is not rendering Audio with the final output! i tried to output in all type of formats, different projects, change audio settings, But its not outputting Audio, just a silent track! the only solution i found is to render AE compositions from Media Encoder!


                      I can assure u @hpwg234 its not a problem with your machine.

                      • 8. Re: Audio Preview and Audio Playback Issues in CC 2015
                        Szalam Adobe Community Professional & MVP

                         

                         

                        Same Problem here, uninterpreted playback is the worst thing happened to AE, they should gave us the choice to enable it or not!

                        I agree that CC 2015 has some big issues (many were fixed in the 13.5.1 update, but not all). You do have a choice though; you can continue to use CC 2014 if you don't like CC 2015. And, if you don't have CC 2014, you can install it if you'd like: How to Find and Install Previous Version of Adobe Apps in CC 2015 | Adobe Customer Care Team

                         

                        The reason CC 2015 is so different, is that the AE team is in the middle of a massive change to the architecture of AE. The intent is to make AE much faster, but they're not there yet; CC 2015 is just the first step on that path. The renderer and the user interface are now on separate threads. This means that you don't have to wait for something to be rendered for you to be able to interact with AE. This is a huge productivity boost in theory (and in practice for many users too). Unfortunately, there are still a number of issues that are being worked out. (Fewer than I expected though, considering how different AE is under the hood.)

                        But you couldn't get the choice to enable it or not because AE's code is being rewritten pretty much from the ground up (as I understand it). The uninterruptible preview isn't a feature they've added to AE - it's part of the new system that's coming.

                         

                         

                         

                         

                        After effects 2015 now (After the latest update) is not rendering Audio with the final output!

                        The audio issue is something Adobe is aware of. See this page: known issues in After Effects CC 2015 (13.5) | After Effects region of interest

                        You should be able to render as a QuickTime with audio. Although, I would recommend that you don't use CC 2015 to render. What I do is work in CC 2015 (to take advantage of the snappier interface and improved expression error handling), and then open that file in CC 2014 for rendering (to take advantage of multiprocessing and that it renders audio).

                        • 9. Re: Audio Preview and Audio Playback Issues in CC 2015
                          Agassi27

                          Agree, Adobe is not aware of it and it definitely is a problem.  Their Chat support is clueless. Update didn't fix.

                          • 10. Re: Audio Preview and Audio Playback Issues in CC 2015
                            kanadiou Level 1

                            Unable to previewing correctly any comp...

                            hope it will be better in update, because it's the worst previewing version ever...

                             

                            c24183282e.png

                            but :

                            d7583da692.png

                             

                            for motion graphics it's really really a bad version...

                            • 11. Re: Audio Preview and Audio Playback Issues in CC 2015
                              Paul9445622

                              PLUS After effects 2015 now (After the latest update) is not rendering Audio with the final output! i tried to output in all type of formats, different projects, change audio settings, But its not outputting Audio, just a silent track! the only solution i found is to render AE compositions from Media Encoder!

                              Hi,

                              Exactly same bug here with lastest AE and windows 7 pro 64 bits ( realtek audio driver )

                              • 12. Re: Audio Preview and Audio Playback Issues in CC 2015
                                kanadiou Level 1

                                yes, me too.

                                 

                                i found a way :

                                i export a mov animation file but untick video output, i have the audio in a mov file that way, but i need to reimport the audio file and video file, and next export to media enc to have a correct file.

                                I prefer to render my animation mov files or avi files from after more than media enc

                                • 13. Re: Audio Preview and Audio Playback Issues in CC 2015
                                  Szalam Adobe Community Professional & MVP

                                  paul9445622 wrote:

                                   

                                  PLUS After effects 2015 now (After the latest update) is not rendering Audio with the final output! i tried to output in all type of formats, different projects, change audio settings, But its not outputting Audio, just a silent track! the only solution i found is to render AE compositions from Media Encoder!

                                  Hi,

                                  Exactly same bug here with lastest AE and windows 7 pro 64 bits ( realtek audio driver )

                                  Read my post immediately after the one you quoted. This is an issue that you can workaround until the fix coming at the end of this month. There are multiple ways to work around it.

                                  1. Render as a QuickTime

                                  2. Render with the Adobe Media Encoder

                                  3. Use CC 2014 to render (bonus: CC 2014 can render with multiprocessing which may or may not help your project [the thing was pretty buggy - thus this re-architecture of AE]).