6 Replies Latest reply on Dec 16, 2006 5:05 AM by quimkaos

    getURL

    quimkaos
      i'm geting a litle anoyed with this

      i'm using this code on a botton:

      on(release){
      getURL("conteudo.html", "_mainFrame");
      }

      when i click on the botton in a single html i'll get the url but when i use it in frames nothing appends... what am i doing wrong here

      plus dreamweaver semas to have some major bugs in frame manipulation

      thanks
        • 1. Re: getURL
          quimkaos Level 1
          o lovely seams i'm going to downgrade my version of flash...
          • 2. Re: getURL
            Level 7
            quimkaos,

            >o lovely seams i'm going to downgrade my version
            > of flash...

            Look, I know you're frustrated, but how is sarcasm going to help? Flash
            gets better with each new version, so downgrade if you like, but I'm happy
            with the improvements in 8.

            In this code ...

            on(release){
            getURL("conteudo.html", "_mainFrame");
            }

            ... you said "nothing happens" when you use it in frames. By frames, I'm
            guessing you mean an HTML frameset, with at least one frame in it. Have you
            given your frameset's frame a name or id of _mainFrame?


            David Stiller
            Adobe Community Expert
            Dev blog, http://www.quip.net/blog/
            "Luck is the residue of good design."


            • 3. Re: getURL
              Level 7


              David Stiller wrote:
              > quimkaos,
              >
              >> o lovely seams i'm going to downgrade my version
              >> of flash...
              >
              > Look, I know you're frustrated, but how is sarcasm going to help? Flash
              > gets better with each new version, so downgrade if you like, but I'm happy
              > with the improvements in 8.
              >
              > In this code ...
              >
              > on(release){
              > getURL("conteudo.html", "_mainFrame");
              > }
              >
              > ... you said "nothing happens" when you use it in frames. By frames, I'm
              > guessing you mean an HTML frameset, with at least one frame in it. Have you
              > given your frameset's frame a name or id of _mainFrame?
              >

              In addition, words like FRAME or mainFrame are reserved and flash often fail
              calling them properly. Use something more unique like "MyPantsStinks" or "whatever_frame"
              Don' forget to test on server, not just locally. Due to some changes in browsers and
              the player not full browser - flash functionality can be obtain. Some things has to be
              tested on server.
              • 4. Re: getURL
                quimkaos Level 1
                works fine if i export it in flash 7....

                and david ya it's geting better each new version, but in version 8 i just got lots of turnarownds. and yes i'm geting frustrated, tho flash is 1 of my favorite softwares.

                urami: i doubt it but i'm going to try
                • 5. Re: getURL
                  quimkaos Level 1
                  nothing to do with FRAME or mainFrame. i tested with flash 8 and it works in apache fine so probably it's a browser problem:

                  locally it dosent work
                  online it does

                  testing with firefox later...
                  • 6. getURL
                    quimkaos Level 1
                    locally firefox opens the frame but in a new tab...