15 Replies Latest reply on Aug 17, 2017 10:55 AM by cybobear

    dx tool failed: Could not create the Java virtual machine

    FlashHelp2015 Level 1

      Hi, apologies if this is in the wrong place!

       

      I've  been trying to create an app (one of the templates) in flash professional CS6 for android.

       

      When I publish I get the following error almost instantly.

       

      "dx tool failed: Could not create the Java virtual machine"

       

      I've tried using the 17.0.0.144 sdk and 18.0.0.180 sdk.

       

      I was successfully making apps with the 17.0.0.144 sdk but I recently reformatted  my pc and when after reinstalling  everything, it failed to work.

       

      Earlier versions of the sdk such as 3.2 don't work either, it just  sits on publishing  and nothing happens. This happened before the pc format but upgrading the sdk to 17.0.0.144 worked fine. I assumed 3.2 was just too old to be compatible with my device.

       

      I've tried the 2 most recent java development kits just in case and re installed flash pro. But nothing works.

       

      The only other thing that's changed from when it worked to now other than my pc reformat is my device has upgraded to android 5.0. But I feel the error happens too fast for it to be a problem on the phone. In fact the error appears with the device disconnected.

       

      Sorry for the long question, and thanks in advance for any help.