1 Reply Latest reply on Aug 28, 2015 3:04 AM by megharajdeepak

    Building for iOS 8 64 bit.  URGENT - please!!

    SaltTheMan Level 1

      I've detailed the entire ordeal here at stackoverflow  http://stackoverflow.com/questions/31765612/update-flash-builder-mobile-app-to-use-64-bit- with-air-sdk-18-0

       

      I am having a terrible time updating my Flex Project to use 64bit and iOS 8.  I have to update because when I use Adobe Air SDK 14 I get the following error while uploading my release version via the Application Loader.

       

       

      Screen Shot 2015-08-01 at 12.29.16 PM.png

       

       

      I've followed all of the instructions listed in the following, but nothing works:

       

       

      http://easynativeextensions.com/making-your-ios-apps-universal/

       

       

      https://helpx.adobe.com/flash-builder/kb/overlay-air-sdk-flash-builder.html

       

       

      https://helpx.adobe.com/x-productkb/multi/how-overlay-air-sdk-flex-sdk.html

       

       

      When I change the line in my air descriptor mxl file to:

       

       

          <application xmlns="http://ns.adobe.com/air/application/18.0">

       

       

      I get the following error:

       

       

      Screen Shot 2015-08-01 at 12.33.44 PM.png

       

       

      I've downloaded the Air SDK from this page: http://www.adobe.com/devnet/air/air-sdk-download.html

       

       

      I tried using both the main link and the Flex specific SDK only link.

       

       

      Screen Shot 2015-08-01 at 12.34.32 PM.png

       

       

      Then I installed the Air SDK in /Applications/Adobe Flash Builder 4.7/eclipse/plugins/com.adobe.flash.compiler_4.7.0.349722

       

       

      Screen Shot 2015-08-01 at 12.36.36 PM.png

       

       

       

       

       

       

      Also, I used the Apache Flex SDK installer to get the latest flex SDK to be used with Air SDK 18.

       

       

       

      Screen Shot 2015-08-01 at 12.39.50 PM.png

       

       

      It seems to have installed fine

       

      Screen Shot 2015-08-01 at 12.38.01 PM.png

       

       

       

      As you can see I've tried multiple versions.  I also select the air version in my Flex Project compiler path.

       

       

      Screen Shot 2015-08-01 at 12.40.38 PM.png

       

       

      I even tried overlaying the SDK in the Flash Builder SDKs folder.

       

       

      Screen Shot 2015-08-01 at 12.42.49 PM.png

       

      Still, I always get the error when I try to set my app descriptor XML line to 18.0

       

       

          <application xmlns="http://ns.adobe.com/air/application/18.0">

       

       

      I can set it to 16.0 and the application will build.

       

       

          <application xmlns="http://ns.adobe.com/air/application/16.0">

       

       

      But then when I build, my app has a ton of UI problems.  Spinners go crazy and tab bars, buttons, and layout all have problems.  My app goes from looking like this:

       

       

      IMG_0034.PNG

       

       

      To this:

       

       

      IMG_0042.PNG

       

       

      Why does the UI get so messed up?  Is it because AIR is not referenced properly?

       

       

       

       

      I have no idea what to do... I am urgently trying to release my app, but I am stuck on this.  Please help.   Thanks for reading.

       

       

       

       

        [1]: http://i.stack.imgur.com/sRDVu.png

        [2]: http://i.stack.imgur.com/jAMJg.png

        [3]: http://i.stack.imgur.com/UxbCg.png

        [4]: http://i.stack.imgur.com/3aMra.png

        [5]: http://i.stack.imgur.com/nKuGs.png

        [6]: http://i.stack.imgur.com/HashD.png

        [7]: http://i.stack.imgur.com/oEkRq.png

        [8]: http://i.stack.imgur.com/LnxV2.png

        [9]: http://i.stack.imgur.com/MCQka.png

        [10]: http://i.stack.imgur.com/3URF8.png