2 Replies Latest reply on Aug 11, 2015 1:24 PM by lori sortino

    Canon 5D Mark III RAW formats not supported in LR 3.0.  What are my options?

    lori sortino

      Have been very happy working in my LR 3 until I tried to upload the RAW files from my newest camera body, the Canon 5D Mark III.  I called Canon and they advised me to talk to Adobe LR.  Is there any way to get this to work with my version of LR or do I have to upgrade?  Searched and didn't find anyone else posting this issue, which I thought was odd.  Answers and options TRULY appreciated!!!  Thank you.

        • 1. Re: Canon 5D Mark III RAW formats not supported in LR 3.0.  What are my options?
          99jon Adobe Community Professional & MVP

          Why not get the latest version LR6? Your new camera probably deserves the improved algorithms, notably highlights and shadows which replaced fill light and recovery a long time ago. I would never go back to LR3. You can buy from the following link. After clicking "Buy" change from Full to Upgrade; then select your existing LR product from the drop-down menu and the correct pricing will be displayed. Then simply choose “Add to Cart”

           

          https://www.adobe.com/products/catalog/software._sl_id-contentfilter_sl_catalog_sl_softwar e_sl_mostpopular.html

           

          Or you can take a 30 day free trial via the Creative Cloud to test what’s new (some new features are only available to CC subscribers) and after the trial it’s possible to convert the CC version to the LR6 stand-alone version, upon purchase of a serial number and without any further installation. In either case make sure your computer meets the minimum system requirements.

           

          Compare Lightroom versions | Adobe Photoshop Lightroom CC

           

          Minimum system requirements

          Windows®

          • Intel® or AMD Athlon® processor with 64-bit support
          • Microsoft® Windows® 7 with Service Pack 1, Windows 8, or Windows 8.1
          • OpenGL 3.3 and DirectX 10 capable graphics card for GPU related functionality
          • 2GB of RAM (4GB recommended)
          • 2GB of available hard-disk space
          • Internet connection required for Internet-based services

            Mac OS

          • Multicore Intel processor with 64-bit support
          • Mac OS X v10.8*, 10.9, or 10.10
          • OpenGL 3.3 capable graphics card for GPU related functionality
          • 2GB of RAM (4GB recommended)
          • 2GB of available hard-disk space
          • Internet connection required for Internet-based services

          * GPU functionality only available on Mac OSX 10.9 or 10.10

          • 2. Re: Canon 5D Mark III RAW formats not supported in LR 3.0.  What are my options?
            lori sortino Level 1

            Thanks - you make a great point about features in the newer version that I'm not aware of since I just sit at my desk using the old version.    There is still a stand-alone version of the software then?  That's really all I need.  I appreciate the links and information you shared (so quickly).