9 Replies Latest reply on Aug 11, 2015 7:24 PM by JimHess

    Please help!! I am getting an error message that reads: The Lightroom catalog named "Lightroom Catalog" cannot be opened because it is too new to be used by this version of Lightroom. Would you like to select a different catalog?

    beccah73708069

      I am a photographer and currently have Lightroom 4 and just purchased a new laptop (PC user). I needed help installing Lightroom onto my new laptop so I chatted with a representative online and was able to get the link to download LR4. I have successfully downloaded it to my new laptop but am having an issue getting it to open. I am getting an error message that reads: The Lightroom catalog named "Lightroom Catalog" cannot be opened because it is too new to be used by this version of Lightroom. Would you like to select a different catalog? *Please help!!! I have no clue what any of this means and have client images to edit! THANKS!!!