2 Replies Latest reply on Aug 12, 2015 1:31 AM by jonathan+7007

    run Lightroom as administrator

    jonathan+7007 Level 1

      All,

      I run Win7 Pro 64-bit. When I updated from LR5.7 to LRCC the program started to post a UAC dialog before running. It was suggested that I need to run the program as an administrator, which I already do. That is, I run my everyday operations on an account that has elevated status, although it is not "the" Administrator Account that Windows first installs.I was able to update both Creative Cloud and the few programs I run from CC without seeing UAC prompts. If I click PhotoshopCC on my Taskbar it starts without a UAC prompt.

       

      I have gone to the lightroom.exe file in the User folders and checked Properties.Under "Details" it calls itself version 6.1.1. Oddly the folder itself is called "Lightroom" not "LightroomCC". Anyway, permissions for administrators are all "full control". If I right-click and choose "Run as Admin..." the program starts but I still get a UAC prompt.

       

      I tried removing the LR icon on my Taskbar and dragging the lightroom.exe that I had confirmed should be running with elevated priv directly to the 'bar. Clicked that and got the UAC again.

       

      Google searches side step the issue of starting from inside CC and I can't find info that addresses my specific fail.

       

      I am trying to think of a situation where the UAC step will stop something that needs to happen automatically. If there is nothing I guess it's a "puzzlement" and I have to live with it... Some future plug-in requirement?

        • 1. Re: run Lightroom as administrator
          Akash Sharma Adobe Employee

          Hi Jonathan,

           

          Did you tried Going in C:\Program Files\Adobe\Adobe Lightroom  Lightroom.exe>>Right Click Properties>>Compatibility

          Uncheck "Run this Program as Administrator".

           

          Also check what the UAC in Control Panel is set to.

          UAC.png

           

          Let us know if this helps

          Akash

          • 2. Re: run Lightroom as administrator
            jonathan+7007 Level 1

            Akash,

            Thank you! No UAC prompt abd it seems to load faster.

             

            The UAC setting was exactly as I had it before, no change there.

            But earlier advice I was given here in the forum by another user was that I *must* run Lightroom as an administrator so although I did not use the "Compatibility" tab I tried to set that program to do so. This seems to negate that. But I am glad this works.

             

            Weird that the program doesn't live in a folder named "Lightroom CC".

             

            Again, thanks.

             

            jonathan7007