5 Replies Latest reply on Dec 11, 2006 8:39 PM by shachah

    Dynamically loaded image blicks with animation

    shachah
      Hey everyone.

      I've recently run into a little glitch with this site i'm working on.

      On the about me page of the site, I have an externally loaded image using the loadMovie function. The only problem i'm running into is that it blinks after the animation of the mask that i'm using finishes. It then blinks again when a button is clicked to go to another page. I know that the loadMovie function is the problem, but i need the image loaded dynamically so that the client can change it in the future....

      The problem can be see here http://frankelphotography.com/fpsiteHelp.swf

      fla can be found at www.frankelphotography.com/fpsiteHelp.zip

      think you could help me out?

      Thanks,
      God Bless

      PS. what's a good way to make sure that the photo is loaded competely before the user gets to the 'page'? So that the animation can be seen?

      Thanks for any help.
        • 1. Re: Dynamically loaded image blicks with animation
          shachah Level 1
          Oh yea, and i am using Flash MX, so i don't think that i can use the moviecliploader class either... what a bummer.
          • 2. Re: Dynamically loaded image blicks with animation
            shachah Level 1
            Anybody have any ideas?
            • 3. Re: Dynamically loaded image blicks with animation
              Generave
              I didn't see any blinking, so I'm not really sure exactly what you are talking about. When I see blinking, I look for places where I forgot to put a stop() action in a frame. That's usually the culprit.

              There might be a way to get some sort of loaded response, but I am not sure what it is at this time.
              Unless you are working with frequently changing pictures, it might be simpler to do this:

              1) Create a new FLA with only one frame and one picture on the stage.
              2) Add in actionscript in the root frame to send a simple response to the movie it is loaded into. For example:
              _parent.ImageLoaded();
              3) Repeat these steps for all your pictures... Yeah, it's tedious, but you could use the same FLA and just switch pictures on the stage, renaming the SWF after ever build.

              In your main FLA, add something like this in a root frame or your .as loaded in the root frame:
              (see below for the code)

              Then after you load all of the pictures you need, it will finally play. Keep in mind that this is simplified and you may want to incorporate some sort of loading display that updates everytime ImageLoaded is called. This is the basic idea though and I'm sure you can expand on it from here.

              • 4. Re: Dynamically loaded image blicks with animation
                Generave Level 1
                By the way, since you're new, it is best not to post follow-ups like "any ideas?" when nobody appears to respond. If someone can respond they will, and if not, then the answer is obvious, "the don't have any ideas."

                In this case, nobody may have responded because, at least for me, I could not find the blinking problem that you are referring to.

                I hope my previous response helps.
                • 5. Re: Dynamically loaded image blicks with animation
                  shachah Level 1
                  Thanks for you help and insight Generave. I'll give that a shot.

                  God Bless