16 Replies Latest reply on Nov 9, 2015 5:22 AM by selfbuildtype

    Data merge not working properly

    joans6216059

      I am using InDesign CS3 and attempting to merge with an excel (.csv) file. I am able to select the data file but it won't move to the next screen where I can select the fields to place into the template.

        • 1. Re: Data merge not working properly
          Pragya Kandari Adobe Employee

          HI Joan,

           

          What OS you are on?

          Would you please attach the file with which you are facing the issue?

           

          Regards

          Pragya

          • 2. Re: Data merge not working properly
            Peter Spier Most Valuable Participant (Moderator)

            Do you see the data fields in the Data Merge palette? You drag, or double click on them to move them to the merge template.

            • 3. Re: Data merge not working properly
              joans6216059 Level 1

              The data fields do not appear in the Data Merge palette but I do find it in the Links palette so that leads me to assume that the file is linked to the document.

              • 4. Re: Data merge not working properly
                joans6216059 Level 1

                I am using OS 10.10.4. It won't let me upload the file but its a standard .csv file with 3 columns and merge fields. Each row has a header.

                • 5. Re: Data merge not working properly
                  Peter Spier Most Valuable Participant (Moderator)

                  Well, CS3 was never designed to run on Yosemite, and it's actually a miracle of sorts that it runs at all. I supect this is one of those things that will never happen for you.

                  • 6. Re: Data merge not working properly
                    johnl72200334

                    Im having exactly the same problem but on InDesign CC 2015 version

                     

                    I can import my cvs file (Like I used to in the past on previous versions of indesign) and its shows that its imported but doesn't show the fields in the palette window for me to drag onto the document

                     

                    pics attached of the layout of my cvs and of the palette window showing no fields

                    Screen Shot 2015-10-26 at 14.08.27.pngScreen Shot 2015-10-26 at 14.09.48.png

                     

                    any help on this would be greatly appreciated and Im sure joans6216059 would appreciate an answer to this aswell

                    cheers

                    • 8. Re: Data merge not working properly
                      johnl72200334 Level 1

                      Awesome, worked wonders thank so much for the advice

                       

                      Also I found a quicker way of deleting the prefs

                      Screen Shot 2015-10-27 at 13.35.02.png

                       

                      Can finally get back to my mail merging

                      • 9. Re: Data merge not working properly
                        selfbuildtype

                        I can confirm this is a problem with Indesign CC2015 (Build 11.1.0.122) on OS X 10.10.5.

                         

                        CS6 can handle the CSV file fine, but CC2015 won't recognise it.

                         

                        On a side note this is the buggiest version of Indesign in quite some time. It's bad news as like many here this is the main app I rely on for my work.

                        • 10. Re: Data merge not working properly
                          selfbuildtype Level 1

                          Thanks. Deleting prefs as suggested fixed this problem.

                           

                          Although weirdly I still encounter the problem if I check Show Import Options. So there is still some bug present.

                          • 11. Re: Data merge not working properly
                            Colin Flashman Adobe Community Professional

                            I don't think this is a bug at all, but rather a strange behaviour. I've just tried to replicate the fault provided by the users here by creating a five-line database from textwrangler as follows:

                             

                            STUDENT NAME

                            Colin Flashman

                            David Lynch

                            John Connor

                            Kermit T.Frog

                             

                            I've saved the text file as "notsureifbug.csv" and in a new indesign document, i've then gone to the data merge palette and gone "select data source" and chosen the file, and THEN i encounter the issue:

                             

                            Screen Shot 2015-11-07 at 11.56.09 am.png

                             

                            However, this is TAKEN OUT OF CONTEXT. You can only cycle through records once a field has been placed into the file. If I make a text frame and apply a field from the data merge palette like so:

                             

                            Screen Shot 2015-11-07 at 11.57.11 am.png

                             

                            I can then cycle through the records.

                            Screen Shot 2015-11-07 at 11.57.50 am.png

                            Can the posters confirm that this is what is happening, or is something else entirely... and then PM me so I can try to replicate the fault on my mac?

                            • 12. Re: Data merge not working properly
                              selfbuildtype Level 1

                              In my case I can't get CC2015 to get to the first stage (first screengrab). It just does nothing when the file is loaded. In CS6 it works as expected. It is definitely a bug.

                              • 13. Re: Data merge not working properly
                                Colin Flashman Adobe Community Professional

                                There is a multitude of factors that could be at play here. If it is a bug, have you reported it to adobe using the Feature Request/Bug Report Form ?

                                 

                                I'm running IDCC2015 11.1.0.122 on a Mac 10.9.5 both here and at work, and DM runs fine... so far as running under Yosemite or El Capitan, I can't confirm.

                                 

                                What steps have you tried to make the merge work on IDCC2015? Have you:

                                 

                                • tried using only the header row and the first record to make sure the file will import with just one record?
                                • tried different saving methods within an application such as textwrangler to use different permutations of UTF options?
                                • how many columns are in the data? If it is just one, is there a difference if the data source has the extension .txt and is imported as tab delimited text as opposed to comma separate values using the show import options feature?
                                • 14. Re: Data merge not working properly
                                  selfbuildtype Level 1

                                  If I'm honest I don't want to get into bug testing / troubleshooting this. I beta test for other software and I don't want to get involved with this if I can as I'm busy at the moment. As CS6 works and is installed I have other options for Data Merge. I have another bug confirmed for CC2015 but this one seems like it is easier to reproduce. The fact that it works in CS6 but not CC2015 shows it is a bug as nothing was intentionally changed between versions.

                                   

                                  If Staff want to contact me I will supply the CSV file. The steps for reproducing this are as simple as it gets:

                                  1. Open Data Merge panel.

                                  2. Load CSV as Unicode UTF8.

                                  3. Nothing happens.

                                   

                                  For what its worth the CSV was created with Apple Numbers. CS6 handles the same file as expected.

                                  • 15. Re: Data merge not working properly
                                    Colin Flashman Adobe Community Professional

                                    I have tried to replicate the fault as described above, and have indeed been able to replicate it. Same steps, but text was created in text wrangler. Wasn't anything complicated, appeared like this:

                                     

                                    Screen Shot 2015-11-09 at 10.41.48 pm.png

                                    Interestingly enough though, when I select the data source with my show import options on, DM does NOT want to place it as unicode, but rather ASCII:

                                     

                                    Screen Shot 2015-11-09 at 10.43.17 pm.png

                                    And unlike the unicode, this DOES import.

                                    Screen Shot 2015-11-09 at 10.43.23 pm.png

                                    But I did notice a comment from one of the Adobe staff on another thread that I believe we're both being updated on. In case it was missed, go here: Data merge doesn't unicode on InDesign CC2015 ?. The quote was from Gaurav Bhargava (Staff) and it read:

                                     

                                    "DataMerge supports Unicode (UTF-16) & may not work correctly with Unicode (UTF-8). Which encoding are you trying to import - UTF-16 or UTF-8? If it's UTF-16 & Data Merge is not able to import the content properly then can you please share the file ( or subset of the file)?"

                                     

                                    That said, if I change the textwrangler file from UTF-8 to UTF-16,

                                    Screen Shot 2015-11-09 at 10.46.29 pm.png

                                    The import options change:

                                    Screen Shot 2015-11-09 at 10.46.18 pm.png

                                    and I can import the file.

                                    Screen Shot 2015-11-09 at 10.46.23 pm.png

                                    I'm starting to think that this may be because of a change in software (perhaps something that's considered an improvement) but has gone unnoticed or undocumented. That said, I too will file a bug report.

                                    • 16. Re: Data merge not working properly
                                      selfbuildtype Level 1

                                      It is very strange to me that UTF16 is supported but UTF8 might not work despite being the more common format between the two. On the other hand I think maybe this refers specifically to Traditional Chinese which can't use UTF8. So in that sense UTF8 might not (probably won't) work for Traditional Chinese.

                                       

                                      In my document there is nothing in there that is outside UTF8. As I say CS6 can import the same file without problems.