4 Replies Latest reply on Aug 15, 2015 7:26 PM by cinnamonreverb

    Light turns 3d layers black

    cinnamonreverb

      Any light other than an ambient light turns all 3d layers black. I have several colored text layers that I want to cast a shadow of onto a solid purple background. I also have an unrelated 2d layer. If I switch "accepts lights" to "off," the color of the text returns, but still no shadows (I am unaware if you need this feature switched "on" to have shadows.)

       

      Things I have already troubleshooted (troubleshot?):

      - no 2d layers between light and 3d layers

      - in active camera mode

      - using adaptive resolution, not draft mode

      - using classic 3d renderer

      - I have "casts shadows" and "accepts shadows" switched "on" on all 3d layers

      - spot light is facing the bg

      - colored text layers are in front of the bg and light is in front of every other layers

      - light intensity is at 500%

      - I have tried copying a light from another composition

      - I have tried copying all other layers in to a new comp and recreating the light

      - I have tried precomping all other layers and using in a new comp and recreating the light

       

      any suggestions are welcome

        • 1. Re: Light turns 3d layers black
          Rick Gerard Adobe Community Professional & MVP

          At the bottom right side of the composition window select 4 views or at least 2 views and make sure that the lights and the camera are on the same side of the layers.  If they are then select all of your 3D layers and your light layers and press the a key twice to reveal the material options and light options. If you don't find something to fix the problem take a full resolution screen shot and drag it to the reply field of this forum or use the little camera icon to upload it and let us take a look.  BTW, make sure that you have the comp set to Classic 3D and not Ray-traced. Here's a setup that works - odd panel arrangement to show you the properties that could cause you problems.

          Screen Shot 2015-08-14 at 3.26.52 PM.png

          • 2. Re: Light turns 3d layers black
            cinnamonreverb Level 1

            I am using classic 3d rendering and there is no camera in the comp. I am somewhat new to AE, so I may be wrong, but I don't think that white box is supposed to be visible when using top and left views. I believe that they are new are may hint at the problem. Screen Shot 2015-08-14 at 9.35.52 PM.pngScreen Shot 2015-08-14 at 9.39.10 PM.png

            • 3. Re: Light turns 3d layers black
              Rick Gerard Adobe Community Professional & MVP

              It looks like the text layer is in the same position as the background (the purple layer) so you need to separate them. Also set the falloff for the light to none. Note how there is separation between the layers in this sample comp:

              Screen Shot 2015-08-14 at 10.43.16 PM.png

              I zoomed in so you could see the separation on the top view so you could see the separation. Try selecting all of your layers and pressing the U key twice. This will reveal all properties not at the default values. As you can see in this example the only thing not at the default for material options is cast shadows for the spot light and for the text layer. If you have any other properties show up then select them, right click and select reset.

               

              The only other thing that might be causing you problems would be layer styles applied to the text layer. If there's anything applied to the 2D png layer then you should either turn off the layer or move it to the bottom.

               

              As an exercise in learning how to use AE type lights in the search help field at the top right corner of AE and read up. You'll find some great resource materials. To find more type Cast Shadows

              • 4. Re: Light turns 3d layers black
                cinnamonreverb Level 1

                So I went through and reset everything that was not at it's default value. This, for whatever reason, made the text turn white. Then I fiddled around with the settings again, and I must've made some mistake at some point along the way, cause my cone angle was set to 4. When I opened it up, my text was miraculously orange! I'm not entirely sure what was wrong in the first place, but nonetheless, I am excited to have resolved the problem. Thank you!!