4 Replies Latest reply on Dec 11, 2006 11:05 AM by Newsgroup_User

    Attachmovieclip problem

    Level 7
      Hello all,

      What i want is to attach a movieclip that is attached to the _root.

      Here is what I have,

      function component(label)
      {
      _root.attachMovie("roundledcomponent", "roundledcomponentHolder",
      this.getNextHighestDepth());
      _root.roundledcomponentHolder._x = 100;
      _root.roundledcomponentHolder._y = 100;

      _root.roundledcomponentHolder.attachMovie("up", "upHolder",
      this.getNextHighestDepth());
      _root.roundledcomponentHolder.upHolder._apha = 50;
      } //end function component


      I am sure the properties for roundledcomponent and up are ok, i do get the
      roundledcomponent.. the up wont attach to the roundledcomponent.

      Any ideas?

      regards,
      Peter


        • 1. Re: Attachmovieclip problem
          Level 7
          Peter, which the problem?

          The property alpha is written incorrectly, but other problems don't exist.

          --
          Regards,
          Erick Souza
          www.ericksouza.com
          • 2. Re: Attachmovieclip problem
            Level 7
            typo in the alpha, but that is not the problem, the up clip does not attach
            to the component. I added a trace an enormous blue dot to verify. not
            getting the dot or the trace output.

            puzzles me


            "Erick Souza" <erickrsouza@gmail.com> wrote in message
            news:elfguk$evu$1@forums.macromedia.com...
            > Peter, which the problem?
            >
            > The property alpha is written incorrectly, but other problems don't exist.
            >
            > --
            > Regards,
            > Erick Souza
            > www.ericksouza.com


            • 3. Re: Attachmovieclip problem
              kglad Adobe Community Professional & MVP
              what's in the output panel after calling component() with the following trace()'s:


              • 4. Re: Attachmovieclip problem
                Level 7
                Fixed it,

                In the end I feel pretty stupid... the code was good.. the movie export
                settings wrong.

                thank you for reading and thinking with me

                Peter


                "kglad" <webforumsuser@macromedia.com> wrote in message
                news:elhhs8$nak$1@forums.macromedia.com...
                > what's in the output panel after calling component() with the following
                > trace()'s:
                >
                >
                >
                >
                > function component(label)
                > {
                > mc=_root.attachMovie("roundledcomponent", "roundledcomponentHolder",
                > this.getNextHighestDepth());
                > trace(mc);
                > _root.roundledcomponentHolder._x = 100;
                > _root.roundledcomponentHolder._y = 100;
                >
                > mc=_root.roundledcomponentHolder.attachMovie("up", "upHolder",
                > this.getNextHighestDepth());
                > trace(mc);
                >
                > }
                >