0 Replies Latest reply on Aug 14, 2015 5:35 PM by rachabot

    Getting a 403 - Forbidden: Access is denied on CF 10 Site

    rachabot

      ColdFusion 10 Enterprise server running on Windows Server 2008 R2.

       

      Scenario 1:

      Established new web site and pointed it to the CF site files, setup proper mappings in CFIDE Administrator, everything works perfectly.

       

      Scenario 2:

      Because I need multiple SSL sites on this server, I needed to move the CF site under the Default Web site as an app/VD.

      Created the site/app and pointed it to the same CF site files in the same folders.

      Created Virtual directory JAKARTA and pointed it to: C:\ColdFusion10\config\wsconfig\1

      Accessing site throws 403.

      Analyzed some logs and traces and it looks as though it is failing on the ISAPI redirect or related file access thereof.

       

      Again, same files, same folders, one as website (works), one as Virtual directory/app off Default Web Site (does not work).

      Both the web site and the app were assigned the same App pool.

       

      I provided the necessary permissions to the IIS_IUSRS group on the folders that make up the site, and also the IIS APPPOOL running the site.

      I then gave the same permissions to the JAKARTA folder/virtual directory above, same thing, 403 - Forbidden.

       

      As a test, I placed random text files in the various folders of the site and was able to bring them up in the browser pointing to them. So I am convinced it is not a permission issue on the files, but something related to a ColdFusion file or process (ISAPI redirect).

       

      Any suggestions would be greatly appreciated.