13 Replies Latest reply on Sep 1, 2015 10:52 AM by Sandee Cohen

    InDesign pauses every few seconds

    KevinAtkins Level 1



      Me (and a colleague) are having major issues with InDesign: it's pausing for a second or two every few seconds. Clicking on text, tools, palettes, typing into layout mode, editing text in story editor – everything, in fact – is a pain because of this slight delay.


      I've trashed prefs, used another user account, deleted fonts, cleared font caches, reinstalled InDesign, turned off other software, shaved my head, scarified my body to look like alligator skin, and then performed a South American cleansing ritual, but still nothing. Oddly, this only started happening this morning, along with a colleagues Mac running the same version of Indd ( on OS X 10.10.5.


      There's not much to report from Console, apart from regular partial memory purges – despite having almost 2GB of free memory (of 16GB total) whilst using InDesign. Here's one such msg:


      17/08/2015 14:09:04.322 Adobe InDesign CC 2015[19628]: [Memory 10.9 Changes]:partial purge level:1


      It doesn't sound like a major issue, but it makes it very hard to copy/paste, select text, or know precisely if an action is being performed, has been performed, or if the app is in the process of quitting!

        • 1. Re: InDesign pauses every few seconds
          Sandee Cohen Adobe Community Professional

          OMG! Is there something about today's date?


          I have the EXACT same issue.


          One thing I noticed is that it only happens with changes in text. Which sorta indicates a font problem. But I've used this font with CC 2014 with no problem.


          The font is Open Source Pro. I thought I got it through TypeKit, but it's not listed


          I just turned off DropBox sync. Perhaps that was causing the problem.


          Also, there have been some problems with Save As. Several times it took way too long and other times I had to force quit InDesign.


          I need to figure out how to get rid of those damn CC Libraries. It keeps popping up everything time I make a text style.


          I'll keep this thread informed.

          • 2. Re: InDesign pauses every few seconds
            Steve Werner Adobe Community Professional & MVP



            When you make a new style, or create a new swatch, at the bottom of the New Swatch or New [Character/Paragraph] Style, uncheck the checkbox to add to CC Libraries. It's a sticky setting.

            • 3. Re: InDesign pauses every few seconds
              KevinAtkins Level 1

              Yes, must be 'Happy Monday' !


              I've found a fix for mine: I noticed that the CC Library wasn't connected. I couldn't get it to connect, no matter how many restarts etc, so I used Activity Monitor to Force Quit the CCLibrary process.


              After that, it connected without a hitch, and is now working fine ... and continuing to, fingers crossed.


              Steve, I had noticed that Adobe had done the usual thing of turning on add to libraries by default, so I've turned this off which should hopefully keep it running a little sweeter!



              • 4. Re: InDesign pauses every few seconds
                Sandee Cohen Adobe Community Professional


                Glad you found a solution. There's definitely something wrong with my Creative Cloud services. My CC menu icon will often get stuck with the panel open and no amount of clicking will hide it.

                I've fixed my problem, for the moment, by unsyncing all the TypeKit fonts I had.

                Fortunately the project I'm working on only uses Source Sans Pro (not Open Source) which is not a TypeKit font.

                I'll deal with the TypeKit and CC issues later.

                It very well may be the CC libraries. This is definitely a problem where something is trying to access something across the inter-something.

                • 5. Re: InDesign pauses every few seconds
                  Sandee Cohen Adobe Community Professional

                  I spoke too soon. After about 30 minutes of work, the beachball reappeared.

                  I've quit InDesign, deleted the default CC Library that had been created, and Quit Creative Cloud, and the CCLibrary process.

                  Well, at least I know it's not TypeKit.

                  I hope it's not the font I'm using.

                  1 person found this helpful
                  • 6. Re: InDesign pauses every few seconds
                    KevinAtkins Level 1

                    Sorry to hear you're still having issues, Sandee. I never got the beachball on my Mac, just pauses ... pauses ... endless pauses ...


                    Fonts are usually the #1 culprit, in my experience (which is preeeettttyy long), so I spent some time trying to prune them and find a culprit. As you know, it wasn't fonts in the end!


                    I've not had any issues with TypeKit, but I imagine that network issues of the type experienced with CCLibrary would cause a similar issue, as it tries to sync to the font server. Source Sans Pro should be fine (it was Google's first font, so is pretty established, even as a Desktop font), and I've used it on numerous things without a hitch. It's possible your copy is kaput, though, so you could try re-downloading it. And, of course, any font live on your system can affect InDesign, not just those referenced within an Indd file!


                    One option to rule-out TypeKit is to package your document (with all fonts and TypeKit on), then turn TypeKit off, and use the local, packaged fonts for working. Not 100%, but might help narrow down the problem. You could also try giving the file (or a similar file that exhibits the same behaviour if there's commercially sensitive content) to another Indd user, and seeing if the affect is mirrored on their system (although they'd need to have identical versions of the app, and ideally the OS).

                    • 7. Re: InDesign pauses every few seconds
                      Kevin Parrott Level 2

                      Hi All

                      sort of related because I believe it is font related, Indesign CC2015 & 14 when using separations preview and selecting Separations, Indesign

                      slows to a near halt, showing beach ball,  Makes ID nearly in-operable, turning it off takes upto a minute.


                      I have cleaned out all my damaged fonts, (I use Font Agent Pro), done all the usual stuff, reboot, run smasher, permissions, safe boot etc

                      yet he problem keeps coming back

                      1 person found this helpful
                      • 8. Re: InDesign pauses every few seconds
                        KevinAtkins Level 1

                        Steve, is there any way Adobe CC libraries can be turned off permanently?


                        My problem has returned, and it is now impossible to do any productive work in InDesign: every task results in a two to three second delay and beach ball. This is not a required feature for me, and is actively preventing the app from doing its job. I know not everyone will have this issue, but I'm obviously not the only one.


                        I can force quite the process in Activity monitor, but it keeps returning.

                        1 person found this helpful
                        • 9. Re: InDesign pauses every few seconds
                          Steve Werner Adobe Community Professional & MVP

                          No, I don't believe there is at this time.

                          • 10. Re: InDesign pauses every few seconds

                            I took a video of it happening to me. Have we figured out a solution yet? InDesign Pausing - YouTube

                            • 11. Re: InDesign pauses every few seconds
                              Sandee Cohen Adobe Community Professional

                              I closed all my Typekit fonts. Closed all traces of CC Libraries. And I was able to do some work this morning. But it wasn't a full session.


                              One thing I have to add is the text I am working on is heavy with anchored graphics as well as very complicated numbered lists.


                              But I was able to work today. (Of course today's not a Monday.)

                              • 12. Re: InDesign pauses every few seconds
                                KevinAtkins Level 1

                                Okay, I'll have to live with it then.


                                In desperation, I've had to uninstall and reinstall InDesign. This has fixed it before, and it seems to be okay now.


                                Perhaps unsurprisingly, the issue appears to be more likely to happen to me if there has been any type of network outage. We had an issue with our LAN yesterday, which seems to have kickstarted the InDesign problem: I imagine that this causes the sync to fail, initially, but it then never fully recovers and causes InDesign to lag-out.


                                I'll keep an eye open and see what occurs!

                                • 13. Re: InDesign pauses every few seconds
                                  Sandee Cohen Adobe Community Professional

                                  I've been working several days now without the slowdown. Enough time that I actually forgot all about the problem.


                                  However, I've been very careful with what fonts I'm using.


                                  And I totally have turned off any syncing of text styles and swatches in the CC Libraries.


                                  I suspect it was the CC Libraries.