1 Reply Latest reply on Aug 21, 2015 7:45 AM by egosfera

    Cannot install add-on.

    egosfera

      Hello,

       

      I have the last version of Photoshop CC 2015: Adobe Photoshop Version: 2015.0.1 20150722.r.168 2015/07/22:23:59:59 CL 1032107  x64

       

      I wanted to install an add-on, Luminosity Masking Panel (https://creative.adobe.com/addons/patches/22663).

      This add-on was last published on the 4th of August, 2015. So it is updated after the last version of Photoshop.

       

      Installation through Creative Cloud desktop app didn't work, so I tried to install via Adobe Extension Manager.

      I have downloaded the XZP package, triggered the installation, but no luck: "This extension cannot be installed, it requires Photoshop version 13 or greater.".

       

      I suppose I have a version greater than 13.

       

      Looking into the logs of Adobe Extension Manager, I get:

      [Error] Thu Aug 20 20:36:06.442 2015 (ExtensionBase.cpp, 129) -CExtensionBase::validateExtension: searchAllSupportedProducts() failed, status = -411!

      [Error] Thu Aug 20 20:36:06.447 2015 (ExtensionBase.cpp, 607) -CExtensionBase::install: validateExtension() failed for zxp X:\.download\LuminosityMaskingPanel_1_3_0.zxp, status = -411!

       

      It seems that the Extension Manager is unable to get the Photoshop version.

       

      I have tried another add-on,  Juicebox for Photoshop (https://creative.adobe.com/addons/patches/22719).

      The message of Adobe Extension Manager is: "This extension cannot be installed, it requires Photoshop version in range of inclusively between 12 and 16.".

      The log says:

      [Error] Thu Aug 20 21:01:03.916 2015 (ExtensionBase.cpp, 129) -CExtensionBase::validateExtension: searchAllSupportedProducts() failed, status = -458!

      [Error] Thu Aug 20 21:01:03.916 2015 (ExtensionBase.cpp, 607) -CExtensionBase::install: validateExtension() failed for zxp X:\.download\JuiceboxforPhotoshop_1_4_4.zxp, status = -458!

       

      I have Photoshop and Extension Manager up to date.

      Photoshop works flawless. So Lightroom.

       

      The Creative Cloud desktop app has the file sync turned on and it is up to date.

      Until now, any sync worked perfectly.

       

      No chance to install add-ons. What should I do ?

       

      Regards !

        • 1. Re: Cannot install add-on.
          egosfera Level 1

          I have managed to install the add-ons using the ExManCmd tool.

           

          Searching through discussions I have found that Extension Manager is discontinued, https://www.adobeexchange.com/resources/27.

          Extension Manager is not supposed to work with Photoshop CC 2015 and, indeed, it doesn't work, at least in my case.

          The link states that ExManCmd tool can be used to install add-ons for Photoshop CC 2015 and, again, this is true in my case.

          I have managed to install the add-ons I wanted using the last version of Photoshop CC (last update was on the 22nd of July).

           

          But I must say I am somehow disappointed by the fact that Extension Manager issues no warning when it is installed.

          It should display a notice letting you know that it is discontinued.

           

          Furthermore, the Extension Manager core has been included into Creative Cloud desktop app.

          It didn't work for me. Maybe it is my system fault, or not. Anyway, I have a slight feeling of unreliability about all this Adobe cloud platform.