2 Replies Latest reply on Dec 6, 2006 11:16 AM by Newsgroup_User

    member("qrs"). text = Property not found?!

    BigDaddy Level 1
      Hi,

      Every so often, my scripts give me the following:

      member("qrs").text = Property not found

      I can't guess why I have to go back and rename my field members.

      Does anyone have any idea why this happens OR how to fix it?

      Thanks,
      BigDaddy
        • 1. Re: member("1"). text = Property not found?!
          Level 7
          On Wed, 06 Dec 2006 19:06:05 GMT, BigDaddy posted in
          macromedia.director.lingo:

          > I can't guess why I have to go back and rename my field members.

          Are you setting the fileName property of those members? If so, I think
          Director will rename them to the filename sans extension.


          --
          Mark A. Boyd
          Keep-On-Learnin' :)
          • 2. Re: member("qrs"). text = Property not found?!
            duckets Level 1
            Perhaps you are accidentally creating another cast member with the same name, at an earlier position in the cast. When you specify a cast member by name, it will always find the first cast member with that name.

            Eg, you have a text member called "qrs" as cast member 5. Then you create a bitmap member also called "qrs" as cast member 1. This will trigger the error you describe as the director will always find the first cast member (the bitmap one).

            hope this solves your problem,

            - Ben