5 Replies Latest reply on Oct 17, 2015 6:14 AM by Ares Hovhannesyan

    Assertion failed message everytime!

    MrOllywood

      It does not record anything. I've tried even reinstalling the whole AE without luck. Same error again and again making ChA useless. Worked fine the first 10 minutes only. Please help.

        • 1. Re: Assertion failed message everytime!
          Jeff Almasol Adobe Employee

          Hi Oliver... Does the problem occur after creating a new project? If so, does it happen for any artwork/puppet, even if you use the New Puppet in Photoshop (or Illustrator) commands in the Welcome panel or File menu?

           

          If so, can you share the artwork file with us? If you don't want the artwork file to be public, you can send me a shared link to the file (e.g., from Dropbox, Creative Cloud Files, etc.).

           

          Also, are you using Preview 2 of the application, or Preview 1?

           

          Thanks.

          • 2. Re: Assertion failed message everytime!
            MrOllywood Level 1

            Hi, Jeff, very kind for answer. Thanks so much, I have great plans to the use of this incredible little program.

            It's so weird. I just reinstall it all over again from CC - the whole AfterEffects program- , and from a second restart of my mac now (yesterday didn't work) it seems it is working again properly. Obviously it's a glitch. The problem about "Assertion failed error" used to appear to every attemp to record, from your tutorial puppets to the downloaded figurines from your tutorial videos (you know, the cucumber and the cookies guy). The reason of my post was that It worked fine for about 1 hour, I started experimenting and suddenly it started to prompt the pop-up error window.  The Mac has the latest OS 10.10.5 with an ATI Radeon HD 5870 card and the latest upgrade to the CC 2015 suite. The application is on Preview 2.

            So for a couple of hours it began to work fine. I really hope it keeps that way.

             

            That message is when a puppet is not "layered/labeled" properly? Just to get to know the future common mistakes...

            When do you expect to finesse and release it? later this year?

             

            thanks again for your time.

            best regards,

            OM

            • 3. Re: Assertion failed message everytime!
              Jeff Almasol Adobe Employee

              Hi Oliver... That message can appear in different scenarios -- we have a task here to make those error messages more specific to help troubleshoot the issues. If the issue reappears, please press Cmd+F12 to open the Console panel to see if there are any additional error messages in it. That'd be helpful. You can close the Console panel when not in use. It's just there to help with debugging. Thanks.

              • 4. Re: Assertion failed message everytime!
                Ares Hovhannesyan Adobe Community Professional

                Hi Jeff,

                 

                I have the same "Assertion failed message everytime!". I am on  Win 7,

                I reinstall it now but bug still there. Here is the screenshotCapture.PNG

                I use the New Puppet in Photoshop (or Illustrator commands in the Welcome panel or File menu.

                It happens when I finish recording.


                Here is code after the bug (Ctrl+F12)

                <5476> <Stage> <5> StartRecording

                <5476> <Animal> <5> assertion failed!

                <5476> <LuaPCall stackdump Boolean: > <1> false

                <5476> <LuaPCall stackdump String: > <1>

                <5476> <Animal> <5>

                    0: global   assert                         - C

                    1: method   setTrimOutTime                 - Lua

                    2: method   addTrackAndTrackItem           - Lua

                    3: field    stopSceneRecording             - Lua

                    4:          [unnamed]                      - Lua

                    5:          [unnamed]                      - tail

                    6:          [unnamed]                      - Lua

                    7: global   pcall                          - C

                    8: method   send                           - Lua

                    9: upvalue  ?                              - Lua

                   10:          [unnamed]                      - Lua

                   11: method   stop                           - C

                   12: upvalue  ?                              - Lua

                   13:          [unnamed]                      - Lua

                ---------------------------------

                <5476> <Animal> <5> assertion failed!

                <5476> <LuaPCall stackdump String: > <1>

                <5476> <LuaPCall stackdump String: > <1>

                <5476> <Animal> <5>

                    0: global   error                          - C

                    1: method   send                           - Lua

                    2: upvalue  ?                              - Lua

                    3:          [unnamed]                      - Lua

                    4: method   stop                           - C

                    5: upvalue  ?                              - Lua

                    6:          [unnamed]                      - Lua

                 

                 

                I connect microphone ...the "Assertion failed message gone"!. But I cant here the audio after recording

                • 5. Re: Assertion failed message everytime!
                  Ares Hovhannesyan Adobe Community Professional

                  It seems I find a solution.

                   

                  That is.

                   

                  Reinstall AE ... but after reinstall go to Documents/Adobe/Character Animator and delete Preview folder. Its include Preview 1 files.

                   

                  Now I haven't bug Assertion failed message without microphone.

                   

                  Ares