6 Replies Latest reply on Aug 30, 2015 3:03 PM by A.T. Romano

    avi files play on computer with windows 8.1, but it won't let me burn in premier elements 9 - says no codec

    mnemm

      Hi,

       

      I was trying to burn some videos onto a DVD and when I try to load .avi files, premier says it can't open it and I may not have the correct codec.  But these files play on windows media player, so doesn't that mean that I do have the codec?

       

      Thanks

        • 1. Re: avi files play on computer with windows 8.1, but it won't let me burn in premier elements 9 - says no codec
          A.T. Romano Level 7

          mnemm

           

          Premiere Elements 9 on Windows 8.1 (assumed 64 bit). Are you working from the 9.0.1 update of the program?

           

          Please confirm - this is not a burn to disc problem, but rather an import problem.

           

          What are the properties of the avi files and where did they come from? AVI is just a file extension (wrapper format). We need to know the video and audio compression used in the file. Do you have AVCHD.avi, MotionJPEG.avi, Xvid.avi, DV.avi, or something else?

          If you do not know, then let us know the brand/model/settings of the camera that recorded the video, and we will try to figure it out from that information. If we have problems getting that information from the camera details, then download and install the free codec utility named GSpot and let us know the readings for Video Name, Codec, Status as well as Audio Name, Status.

          GSpot Codec Information Appliance

           

          Any questions or need clarification on the above, please do not hesitate to ask.

           

          Thank you.

           

          ATR

          • 2. Re: avi files play on computer with windows 8.1, but it won't let me burn in premier elements 9 - says no codec
            mnemm Level 1

            Hi,

             

            Thank you for the quick response.  I'm a newbie to this stuff, so bear with me, because I have no idea how to check the type of video/audio compression used.  I'm good with following directions, so if you could tell me how to figure that out, I can try to get the info for you.  Yes, it is an import problem, not a burn problem, at least not yet.

             

            The camera used is a canon powershot SD950 IS - Digital elph.

             

            Hope that helps.

             

            Thanks again

            • 3. Re: avi files play on computer with windows 8.1, but it won't let me burn in premier elements 9 - says no codec
              A.T. Romano Level 7

              mnemm

               

              Great job. You gave us the most likely answer to your issue...your camera is recording with the video compression named MotionJPEG. So, you have a Motion.JPEG.avi file that Premiere Elements is known to have problems with. This is sort of a classical question/answer. At least 3 ways to go on this....

               

              1. Look at what came with the camera....determine if there is a utility that came with the camera...if there is, install it to determine if it will give you the MotionJPEG video codec that Premiere Elements will recognize.

               

              or

               

              2. Go online, find a MotionJPEG codec to purchase, download, and install. The Morgan MotionJPEG codec has been used in the past by some and has been coming with good tryout period to decide if it is going to work and if it is worth the investment if you are going to stay with recording MotionJPEG.avi and editing it in Premiere Elements.

               

              or

               

              3. Convert you MotionJPEG.avi into another format with which Premiere Elements does not have problems. Please consider the free HandBrake software to obtain a H.264.mp4 that you can import into your Premiere Elements project. https://handbrake.fr/

               

              Please consider. Any questions or need clarification, please do not hesitate to ask.

               

              Thanks.

               

              ATR

              • 4. Re: avi files play on computer with windows 8.1, but it won't let me burn in premier elements 9 - says no codec
                mnemm Level 1

                I was finally able to find my old box for the camera.  There is a digital camera solution disk and here is what is on it for Windows:

                     Canon Utilities:

                • ZoomBrowser EX 6.0
                • Photostitch 3.1
                • Camera TWAIN Driver 6.8
                • EOS Utility 1.1a

                 

                Will any of these have the codec in it?

                 

                Thanks

                • 5. Re: avi files play on computer with windows 8.1, but it won't let me burn in premier elements 9 - says no codec
                  Peru Bob Adobe Community Professional & MVP

                  mnemm wrote:

                   

                   

                  • EOS Utility 1.1a

                   

                  Will any of these have the codec in it?

                   

                   

                  Possibly:

                  MJPEG - How to Handle It

                   

                  See here:

                  Re: APE AVI Problem

                   

                  Another possibility:

                  What tools can I use to convert my video to DV-AVI?

                  • 6. Re: avi files play on computer with windows 8.1, but it won't let me burn in premier elements 9 - says no codec
                    A.T. Romano Level 7

                    mnermm

                     

                    The essential ways to solve the Premiere Elements MotionJPEG recognition issue have already been presented (see post 3). The open matter is which one of the ways best works for you.

                     

                    Thanks for getting back to me with the materials that came with your camera so that we can continue with the discussion in progress in post 3 and your additional posts.

                     

                    Way 1 (referring to post 3) and your information for that....

                    • ZoomBrowser EX 6.0
                    • Photostitch 3.1
                    • Camera TWAIN Driver 6.8
                    • EOS Utility 1.1a

                    I would install the EOS Utility 1.1a. And, if that did not resolve the matter, I would install the ZoomBrowser EX 6.0.

                    It has never been clear whether Premiere Elements does not recognize the codec or whether it is not available to Premiere Elements.

                     

                    If the utility approach does not work, then I would look at the tryout of the Morgan MotionJPEG video codec. If that works, then weigh the merits of investing in its purchase versus converting your MotionJPEG.avi each time with a free program such as HandBrake. HandBrake should be able to do the conversion to H.264.mp4 for batch as well as single file. What are you recording, 640 x 480 at 30 frames per second or something else? Lots of free convertors available for that to DV AVI standard 4:3 and other.

                     

                    Looking forward to your results as your schedule permits.

                     

                    Thank you.

                     

                    ATR