1 Reply Latest reply on Nov 11, 2015 8:00 AM by thelabmonkey

    Node module in Generator doesn't work in production

    Sergey Kritskiy Level 1

      Hello there,

       

      I'm trying to use socket.io in Generator and while it works fine in debug environment, after restarting PS I'm getting an error and Generator plugin doesn't work. It seems that Node can't require the module. I've tried different paths but nothing helps. Log files are clean.

      Does anyone know how to deal with this?

       

      Thanks!

        • 1. Re: Node module in Generator doesn't work in production
          thelabmonkey

          I ran into this with the "ws" socket module and was pulling my hair out. The generator logs were showing that the plugin was running, but the socket wasn't open. On a whim, I checked the file permissions in the prod environment and it was all set to read-only.

           

          Setting the whole plugin folder and all children to not be read-only fixed my socket connection. I'm not certain why, but maybe this will help you.