2 Replies Latest reply on Sep 20, 2015 10:05 PM by pwillener

    You will need to Install the latest Flash plugin to view this page properly.. Steam.. Win 10

    fitzy89 Level 1

      Hi, I am getting "You will need to Install the latest Flash plugin to view this page properly" in steam when trying to view Game trailers.

       

      All suggestions i can find seem to suggest that i install an ActiveX Plugin through internet explorer, however IE10 apparently has an inbuilt Flash plugin and the Flash download page seems well aware of this. Other suggestions included selecting "install for another browser" options when using Chrome or Firefox. I have downloaded the Flash Player Plugin for IE with ActiveX but Windows blocks it saying that it "doesn't have permission to perform this action" and fails the installation.

       

      I can not find anyone else showing this particular issue, but i can't be the only one experiencing it.. Is anyone able to help me?