4 Replies Latest reply on Sep 17, 2015 9:35 AM by RomanPaulov

    How to propagate position of the crop region to 15K photos

    RomanPaulov

      Hi everybody. Maybe my question is weird and stupid but I stuck in this simple problem...

       

      So, I have 15 000 photos from my GoPro camera. I wanna make timelapse video and I use LightRoom for pre-processing. I wanna adjust WB do lens corrections etc etc... It's not a problem.

       

      The problem appears when I crop all these images. Auto sync, manual sync, copy and paste dev settings - doesn't matter which method I use - LR doesn't propagate position of the crop region to all my photos.

       

      My workflow looks like this:

      1. So I select all my images on Develop screen.

      2. I turn on «auto sync» option.

      3. I adjust WB\Lens correction etc... no problems here. LR shows that it's auto-syncing changes. Changes propagate successfully.

      4. I click on Crop tool and crop my first image in the sequence (I decrease size a bit and move crop region a bit). LR shows that it's auto-syncing changes.

       

      Result:

      If I've ever opened some image in Dev Screen or image was visible on the bottom bar of the Dev Screen (timeline - not sure the right way to name this panel) LR propagates position of the crop region to this image. If I've never opened an image and it wasn't visible (I have 15K images... it's a long long tail) LR doesn't propagate crop region position to this image. So... all these images are cropped, but LR put crop region right in the center...

       

      Does anyone know what to do to fix it?

       

      I use Win7 pro, latest LR 2015.

        • 1. Re: How to propagate position of the crop region to 15K photos
          Rikk-Flohr Adobe Community Professional

          Instead of AutoSync, have you tried using the Sync option?

           

          Select all of your images.

          Go to Develop [D]

          On the Most Selected or Target Image, perform your Crop.

          Hit the Sync Button and [Check None]

          Check the Crop options

          [Synchronize]

           

          Does that place your crop properly?

          • 2. Re: How to propagate position of the crop region to 15K photos
            RomanPaulov Level 1

            I've tried to do auto sync, manual sync (what you described) also I've tried to copy developing settings and paste it to all other photos - same result.

            I thought that's because of huge amount of photos, but I've tried to do the same for some small part of my collection (~500 photos). Same happened

            • 3. Re: How to propagate position of the crop region to 15K photos
              Rikk-Flohr Adobe Community Professional

              It is working fine for me. The position, size and aspect ratio of the crop propagate through the entire set.

               

              Try resetting your preferences:

               

              Close Lightroom

              Hold down [Alt/Opt]+[Shift] and Launch Lightroom

              Overwrite the preferences when prompted.

               

              Does that fix it?

              • 4. Re: How to propagate position of the crop region to 15K photos
                RomanPaulov Level 1

                No, it doesn't work...

                Maybe I explain the problem wrong...

                Propagation works... but only for those images I've opened or seen...

                I mean...

                I open Develop screen, turn on auto sync (on other types of sync - same stuff), select all photos, then adjust colors, lens correction, etc.

                Then, if I scroll bottom bar (which is full of photos) to the right, „page“ by „page“, LR like... re-renders these small previews, like... applies my adjustments to these previews... now these previews are like normal fisheye gopro photos, moment later they turn to flat photos with normal geometry - my lens correction works.

                So... if then I crop my first image and move the crop region (auto sync is on), LR propagates my changes differently to all other photos based on the fact was they preview "re-rendered" or not.

                For photos with re-rendered preview LR propagates crop in a right way. Size and position of the crop area is correct.

                For photos from the tail (I didn't scroll so far yet) LR propagates crop in a wrong way. Size of the crop region is right but position is wrong. Position is always in the center.

                 

                So if I scroll bottom bar from end to end it'll help to propagate changes right ) but it's 15K photos here and it'll take enormous amount of time to wait till all these preview re-render.

                 

                I think it's related somehow with lens correction. With «auto» lens-correction is on LR puts crop region right in the center of an image (along the x and y axes). With «auto» correction is off and some manual adjustment of perspective LR puts crop region in the center along the x axis and contains the right position along the y axis.