6 Replies Latest reply on Dec 1, 2006 6:54 AM by duckets

    setpref not working

    uconnman
      I have some shockwave files online that use setpref. Up to shockwave 10 they worked fine--now NG. I tried downloading the full shockwave xtra folder but that didn'work? Any ideas?
        • 1. Re: setpref not working
          duckets Level 1
          When you say they "don't work", what exactly is happening. A script error? Values not returned correctly? Please describe more exactly the symptoms you're seeing, and how they differs from what you are expecting.

          I can confirm that setpref and getpref definitely work in shockwave 10.

          - Ben
          • 2. Re: setpref not working
            Lukewig Level 1
            I've heard of 'problems' calling setPref using Javascript syntax (see this technote) - but no problems with Lingo. Like Duck says, whats the specific problem?

            -- Luke
            • 3. Re: setpref not working
              uconnman Level 1
              Here is the problem--After I click the save button I can not find the saved text file or the prefs folder? The scripting is fine. If I perform a search for the folder or file--It does not show up.
              • 4. Re: setpref not working
                duckets Level 1
                The difference is that since Dir MX 04, the prefs are stored per-user, in each user's application data folder.

                For projectors, look in:

                C:\Documents and Settings\<USER NAME>\Application Data\Macromedia\Director MX 2004

                For shockwave, look in:

                C:\Documents and Settings\<USER NAME>\Application Data\Macromedia\Shockwave Player\Prefs

                In the shockwave prefs folder is a folder named with a random string, and in there are the pref files.

                Hope this helps!

                - Ben
                • 5. Re: setpref not working
                  the real POTMO Level 1
                  Yeah i had the same problem
                  setPref("test", "hello world!") returns TRUE but no file are written.
                  I just let it be and didnt think of it more.

                  Try use _player.setPref() instead and see if that works.
                  • 6. Re: setpref not working
                    duckets Level 1

                    There will be no difference in functionality, whether using _player.setPref() or simply setpref(). It is the change in where the pref files are stored that is the issue.

                    - Ben