2 Replies Latest reply on Dec 5, 2006 1:31 PM by fcpssupport

    Installed CFMX 7 and ORA-01460

    fcpssupport
      I just upgraded from MX 6.1 to 7 and installed 7.0.2 updater. Now it returns the following error:

      [Macromedia][SequeLink JDBC Driver][ODBC Socket][Oracle][ODBC][Ora]ORA-01460: unimplemented or unreasonable conversion requested

      at the following lines of code (located in the custom tag):

      <cfstoredproc procedure="cod.encryp" datasource="#attributes.DSN#">
      <cfprocparam type="InOut" cfsqltype="CF_SQL_VARCHAR" variable="abc" value="#abc#" null="No">
      </cfstoredproc>

      It worked fine on 6.1. Does anyone has an idea why MX 7 returns this error? or have the similar issue?
        • 1. Re: Installed CFMX 7 and ORA-01460
          ksmith Level 1
          Does this occur if you use JDBC? You can use the Adobe driver if you have enterprise or use Oracle's own. If you must use ODBC, try the jadazoom driver instead of sequellink. See this technote - http://www.adobe.com/go/2d2a7a19.

          Lots of Oracle ODBC issues have cleared up by using the latest Oracle Client for your version of Oracle or even a new client. IE use the 10.x instant client to connect to a pre-10 Oracle server. Update the client and ODBC driver itself.
          • 2. Re: Installed CFMX 7 and ORA-01460
            fcpssupport Level 1
            I have the standard edition so don't have CF built-in JDBC driver support. I tried the jadazoom driver but it didn't help - it created another problem.

            I used the type 4 JDBC driver downloaded from the Oracle web site and it finally resolved the issue.

            Thanks for your help.