7 Replies Latest reply on Oct 3, 2015 10:04 AM by DarkoBos

    Latest Lightroom won't import my Fuji x100t files, suggestions please!!!

    DarkoBos

      I am working on a PC, ASUS, very new and not so cheap lap top,  on Windows 10, I have all the latest updates. I did everything that I could think of, uninstalled , deleted preferences etc... I left on import mode for hours and hours while editing photos and also while being away from the computer. Nothing happen , I even tried importing only one photo from the same folder. Still nothing, only says that it is importing with out doing any importing. I have even copy and paste the folder in different location on my computer from pictures folder to a folder on my desktop. I have tried importing with copy, copy to dng and to add, it didnt make any difference , the only way i can import is by using the adobe dng converter before lightroom and importing DNG, but I shouldnt have to do that and I lose a lot of info and quality from my RAW files by doing that. Any suggestions would be super cool appreciated, thank you