3 Replies Latest reply on Oct 5, 2015 10:44 AM by A.T. Romano

    I want to upgrade both Photoshop Elements 11 and Premiere Elements 11 to Elements 14, but my computer is Mac OS X v10.8.5. The specs for Elements 14 shows that the System Requirements are for Mac OS X v10.9 or v10.10. Does this mean that Elements 14 will

    jadam79512055

      I want to upgrade both Photoshop Elements 11 and Premiere Elements 11 to Elements 14, but my computer is a Mac OS X v10.8.5. The specs for Elements 14 shows that the System Requirements are for Mac OS X v10.9 or v10.10. Does this mean that Elements 14 will not work on my computer?