2 Replies Latest reply on Oct 6, 2015 11:34 PM by miked55217429

    I need Indesign I use a Mac 2.16 Ghz Intel Core 2 Duo. Mac os x 10.6.8 It is no longer supported. I can not buy it. what should I do?

    miked55217429

      I need Indesign. I use a Mac 2.16 Ghz Intel Core 2 Duo. Mac os x 10.6.8 It is no longer supported. I can not buy the plan with the monthly payments. what should I do?